strange flickering effects

Hi guys,

Some of the meshes in my animations have some strange flickering effects. At first, I thought it was because I didn’t set them to be smooth, so I selected all the meshes and clicked the “set smooth” button in one of the editing panels, but it didn’t make any differences. The funny thing is that the flicking only happens when I’m moving the camera. I suspect it’s to do with the specular reflection of the meshes not being interpolated across the surface, but I am really not sure, any advice would be appreciated.

Here is an example of a clip that doesn’t flicker:

http://www.cs.mu.oz.au/~jingy/download/videos/scene001.avi

Here is an example of a clip that doesn’t flicker when the camera is still, but flickers when the camera starts moving:

http://www.cs.mu.oz.au/~jingy/download/videos/scene002.avi

Here is an example of a clip that flickers all the way:

http://www.cs.mu.oz.au/~jingy/download/videos/scene003.avi

Thanks a lot.

-D

I was just about to ask a similar question!
Try to Recalculate the normals on your mesh(CTRl + N) and see if it makes a difference.
If not you probably have same problems as myself.
I used to think the flickering might have something to do with the OSA level but i moved mine from 8 to 16 and it made no difference during animation render. Plus rendering to uncompressed avi/mov made no difference either.

My internat connection is slooow so i couldn’t view you .avi’s but does your mesh material have texture with “nor map” activated and the material have a high specularity value? What kind of lights are you using? Does it make a difference if you use another type light instead of lamps?
I have same problem and presume it’s just that my material is too reflective and ‘bumpy’ and thats whats causing the flickering.
Any advice anyone?:o

Maybe this will help


http://blenderartists.org/forum/showthread.php?t=69770&highlight=flickering


i don’t see how OSA has anything to do with the flickering, it clearly is a shading problem. that flickering page you linked didn’t seem to be any help, since in my case, it only happens when the camera moves. i still think it’s the specular reflection not being interpolated across the surface. i also think the way i set every mesh to be smooth is not working either. the button “a” selects all the objects, but when you apply the “set smooth” option, it only sets the last object to be smooth …

A will Select All but only the Active Object (last selected with RMB) will be editable and for all practcal purposes SetSmooth is an edit even though it’s done in object or edit mode. You can try using AutoSmooth to prevent gourand shading bluring the edges of flat surfaces as they extend around curves at their edges (especially problematic with Specular highlights) though you’ll only see the result after rendering (maybe use Border (F10) with Shft-B to select only a part of the scene for speedier tests). You can copy the AutoSmooth value from the Active to all Selected objects with Ctrl-C.

Noise textures (the procedurals) will also flicker but it’s not only when the camera moves, it’s during any anim.

%<

so is there an easy way to “setsmooth” every mesh in the scene? there are a like a few thousand meshes in my scene and i’d go insane doing it by hand.

thx a lot!

I just tested and I was wrong. Set Smooth does in fact work on all selected meshes.

%<

so if i’ve done this to my scenes, why am i still getting the flickering? any ideas?

Does it flicker if you turn smoothing OFF (SetSolid) on the offending meshes?

We had a maze thread once where the flickering was caused by SetSmooth because it randomly caused the sort of black shading you see when you “SetSmooth” a basic cylinder or cube.

If it’s caused by SetSmooth then you have two possible solutions. Edit the meshes with extra loops/edges to help define sharp corners or maybe, as Fligh suggested, set AutoSmooth and see if that helps.

“SetSmooth” is an illusion and doesn’t work well on meshes with sharp edges.

I had to go to the editing buttons window (F9) and select “No V.Normal Flip” on the offending meshes. You might try that, otherwise as the camera moves, the normals could flip resulting in flickering.