strange graphics bug in Cycles with GPU rendering (ubuntu)

hello everyone!

I ran into a strange problem, using cycles and gpu rendering. i’m relatively new to blender, and even more to cycles :wink: i finally got it working with my GT430 graphics card on ubuntu, and was doing a tutorial from blenderguru. but when i try to render an image (and sometimes in the viewport) i get some really strange results.

As you can see on the left image, there’s this big dark rectangle next to the door, an the balcony seems to shine through the wall on the left side. Also the wooden door shows some black rectangles, similar to the big one.
The right image was rendered with the cpu and looks fine.

My system:
Phenom II X4 945 @ 3 GHz
Nvidia GT 430
4 Gigs of Ram
Ubuntu 12.04, xfce desktop

I tried the nvidia developer driver 295.41 (as suggested on the cuda website for my os) and the normal 295.53 Driver(which i think is the newest version for ubuntu), same results.
When i boot windows 7 and try to render there it works just fine, but since i use ubuntu most of the time, i’d like to get it working there! :slight_smile:

EDIT: in the meantime I upgraded to 302.07 beta driver, no difference. it seems to be working correctly in the viewport, though.