Strange GUI layout on a fresh installation of Blender 2.57(b)

I’m on Windows 7 x64 Home Edition having tried installation of Blender 2.57b and Blender 2.57. I was previously doing little tests in Blender 2.x releases and thought I knew the GUI layout.
That’s why I’m quite curious about whether or not the GUI layout has changed in 2.57 or if there is a bug in my setup, Blender or something else. See the attached screenshot of Blender taken on start up.

I tried pressing Space, clicking twice on “Load Factory Settings”, but all I got was that layout looking very different from layouts seen in video tuts on for example.

Uninstalled Blender 2.57b, including removal of any config folder and similar. Then started another installation. No change. So I tried 2.57 … still no change.

Quite accidently I realized some output on top of window after pulling down topmost panel. See the second screenshot on that … That message doesn’t appear on startup, but after trying to load factory settings …


I had the same thing and I read to remove the per install python as the new Blender has it in it installment.

Thanks for the hint, but now I tried installing separate Python (3.2), renaming folder python inside Blender installation folder to python.dis and started blender again. Same strange layout as before.

I’m sure blender is now using separate Python since I started to rename folder “python” first, checking whether starting blender fails or not and it failed indeed missing libraries. Then I installed Python package and on next start of blender it didn’t crash again.

EDIT: Tried setting PYTHONPATH in addition with no change to blender GUI layout.

Run blender as an Administrator

Thanks! That’s actually working … though I don’t like software that requires to be run as administrator. Is blender requiring root access in Linux, too? Back in 2002 with XP it might be tolerable to have existing software requiring this, but in 2011 software shouldn’t be relying on administrator access anymore. Very big con! Looking forward for some .blend trojans …