Strange Issue Of Missing Objects

Hello everyone and good day,

I’ll try to explain this as best I can.

Well, first, I was unable to rotate any bone in Pose Mode, but could successfully alter them in Edit Mode. After I closed Blender to try and resolve this issue, I noticed that my model was completely gone, I can’t see it in Object Mode or in the Outliner, and the bones only showed their root. Yet strangely enough, I can see the model in Edit Mode, and it’s definitely not hidden as I’ve hit alt + H multiple times.
This only applies to the main character model, as other objects in other layers other than the first and second are still visible, and work just fine.

I would just write this off and go to a backup copy I have, however this version that is having the issue has all the animations I’ve done for it up to this point and would rather not lose that.

So far, all I could think to do was restart Blender and restart my computer. I’m very new to it, and so have no idea what this issue is called or how I would ever go about resolving it.
I’ve also checked, and in the render tab, it’s showing that those layers should be visible. They don’t even show up when I render, only when I’m in Edit Mode.

My best guess is that the file somehow got corrupted, but I’m hoping it’s just something I’m overlooking.
If anyone can help me out, I would appreciate it greatly.

Wishing you all well,
-Matthios

Two possibilities I can think of:

  1. Did you hit Alt-H in both Edit Mode and Object Mode? In Edit Mode, vertices, edges and faces are hidden; in Object Mode, entire objects are hidden.

  2. Go to Pose Mode and hit ‘a’ a couple of times until you’re sure all the pose-able bones are selected, then hit Alt-g, Alt-s, Alt-r to make sure you haven’t animated some or all of the rig out into la-la land.

Try #1 first so you don’t lose work unless you absolutely have to.

Thank you for your response, Rontarrant,

I checked into both of your suggestions and nothing worked.

After some messing around, though, I noticed that one of my modifiers on a still selectable object was highlighted red. Deleting that made the rest of it appear. After a bit of random clicking, I somehow managed to click on my model, then delete all the modifiers. After I did this, the model reappeared, but the bones are still only showing their root in pose and object mode.
I figured that I’ll just delete the bones and start over with that, and hopefully I can still use the animations I’ve already made, unless you or anyone else can help resolve that last issue (which isn’t essential at all, but would still be appreciated.)

Thank you again for responding and thank you for your time, I really appreciate it.

Wishing you well,
-Matthios

The bones may be invisible because you don’t have their layers set to visible. Do you know where the bone layers panel is in Properties -> Armature? Might be worth a look before you delete everything.

Just curious: which modifier was the problem?

Rontarrant,

I checked into that and there was no change, all I could see, still, were the root of the bones.
Thank you for the suggestion, though.
I just went ahead and deleted that armature and started over, making sure to copy each bone position in edit mode, then typing all that to the new set. It all works just fine now.

As for which modifiers that were the problem, I believe it was the Mask modifier, although I also had quite a few Armature modifiers, as well. As far as the use of the Mask Modifier, I had two of them set to hide the torso and legs of the model so I could just work on the arms, and they were still set to the correct settings when I deleted them, the only difference being the red outline which, from what I’ve gathered since then, means that what it was assigned to was missing somehow, although I could definitely been wrong as I think I’ve only been working with Blender for maybe three weeks, so I’m still not very clear on the vast majority of what Blender does and how it works.

Wishing you well,
-Matthios

Ah-ha. At this point, I’m going to guess it was the multiple armature modifiers. There should only be one, at most.

So, if this type of thing ever happens again, first thing to check is multiple armature modifiers. For each separate mesh (if you have more than one) make sure you delete all except one… and make sure the one you leave is the same one for each mesh.

For example, most of the time with multiple armature modifiers, they will be named: Armature, Armature.001, Armature.002, etc. This happens when you parent the mesh to the Armature more than once during the course of “trying to get it right.”

Deleting all but the one named Armature will give you the results of the first parenting, but usually the one you’ll want is the last one (in the case above: Armature.002) because that’s the one where you, presumably, got it right.

Rontarrant,

I checked into that to confirm it and you are correct, it was the armature modifiers. When I went back to that file that has the issue and added that to the object, it hid that object.
The only reason I’ve added multiple ones is because using the parenting method, it never seems to assign weights correctly to the desired vertex group. I suppose I need to look into Weight Paint mode a little bit more.

Thank you for your time and suggestions, I really appreciate it.

Wishing you well,
-Matthios