Strange jagged edges on model

Okay so, this is my problem here


See on his leg? getting some odd lines there for no reason.

at first I thought my mess may have been odd but…



when looking at it outside of render it looks fine. and when I’m in edit mode…


still don’t see problem. I checked to see if it was my subdivision mod doing tricks but nothing there and I made sure all vertices are smoothe and even checked to make sure that I had no double vertices. Really at a loss with this

Did you try to recalculate normals?

Yep! I even flipped the jagged areas to see what would happen. Wasn’t pretty

even deleted the faces there and readded them by hand

It’s a mystery then. If you can’t figure it out and you have the file, you’re giving quite a challenge by just showing a portion of your screen that doesn’t give any hint of extra information that might reveal what causes it.

So it’s a guessing game. I’m not in the mood for playing. Maybe I’ll check tomorrow to see who got the closest.

Okay so you don’t know the answer, not sure why you’re so upset about that.

If you want more info just tell me

Did you try the UV project modifier?

never heard of that, may need to research

It’s just one way of telling that if you want an answer, put the information you have upfront so people don’t waste their and your time guessing. Also one way of including the link that is in my signature that tells you how to do that and why.

Sorry buddy but if you want anyone to take you seriously, you need to learn how to communicate properly. You sound like you’re just an angry kid.

I’m 12, what do you expect.

Mostly just for you to treat others with respect.

Looking up the UV project motifier now @DruBan will let you know what happens

UPDATE

so I tried the UV project modifier, not sure what I’m doing still

the jagged edge is still there though, and oddly looks smoother so now a smooth edge?

Nah. I don’t mean any disrespect. It’s just frustrating when people include so little information that it’s really a guessing game. This happens quite often and when one of the moderators or others don’t say “where’s the .blend file”, it can go on and on. Not to mention it can be hard to diagnose even with the file.

There even was a Blender support question just moments ago where user asked help and next sentence was that he/she can’t tell anything about it. Kid you not. Where do you go with that, other than complete silence what that user received. Need something to work with.

Meh, no hard feelings. You’ve posted more than I have here so I’m sure you’ve seen a lot more frustrating folks.

If you need my blend file I’ll post it. I just feel kinda shy showing off everything since I still feel like my work is kinda poor.

This is the first time I’ve just seen random bumps on a mesh that only show up when rendering. Is so odd.

No need to be shy. I have never seen anyone laughed at because their work or because they ask help. I personally don’t care what the subject matter is, what it looks like or how it’s done, unless some of that is what causes the problem. Screenshots don’t have to be pretty either, just informative.

I understand why you would be reluctant to share the file and there are other reasons not to do so (work related, copyrighted material, licence issues, so on) or just don’t want anyone to see, which is fine. In that case it would cause extra work to get an example file but can be done. Could for example select the problematic part of the mesh, ctrl+i to invert selection and X -> delete faces, include relevant external files and save with another name. Then most of the model will be gone, just showcases the problem. All modifiers, helper objects, lights, material settings, world settings, render settings, and such are still there for troubleshooting.

Textures might cause a problem if their licence doesn’t allow sharing. Could leave those out if the problem is still visible, or try another texture. All of this fiddling might even reveal the cause of the problem while you’re preparing the file.

And yea, I still don’t think this will be solved without the file. Can’t even guess if it will be solved with the file but at least people smarter than me have a real chance with it. Outliner in your screenshot suggests that you have parented objects and modifiers on the thing but no idea what those are or how they affect the object and rendering. Could be a shadow, intersecting mesh, wrong modifier order. Too many to ask separately so please upload an example file.

This is the blend file and here’s a better view of the problem


On the original file that’s the only spot that has those ridges. is giving me a headache

Is there another object in the scene perhaps on a different layer? I looks as though there is an intersecting object that is not being rendered but is visible to the renderer.

Not sure that makes sence but if you have multiple objects on different layers just check the render settings to make sure the scene layers you are rendering and the visible layers are st the same.

It’s also possible that an object modifier is causing this. You could try setting any modifiers to not render one at a time to see if you can find the culprit.

Good luck.

That’s a good point!


Here though, you can see there’s nothing else in the scene apart from the object itself. and only modifier is subsurf mod

It’s likely because severely non-planar quads and shading. The light angle is such that the problem area starts to be in a shadow so the shading highlights the problem.


Here’s a piece from the problem area. The quads are skewed, which subdivision surface subdivides twice and non-planar quads get triangulated. The angle between triangles are still enough to give shading artifacts.


Here’s another view. Triangulated version of the problem area and fixed version. I made the quads somewhat planar first and then upped the subdivisions to 3. More polygons, lower angle after triangulation, no shading artifacts.

Similar issue as in this http://www.blenderartists.org/forum/showthread.php?325921-Shading-Issue&p=2569443&viewfull=1#post2569443

Edit: forgot to mention. Object scale is not 1,1,1. It’s unapplied and non-uniform which isin’t good for tools and modifiers and UV unwrapping. Object mode, ctrl+A -> scale to apply. Here’s an example of a problem unapplied scale causes http://www.pasteall.org/pic/show.php?id=72366

Ok I looked at the blend file and to me is seems that there is a problem with you topology flow. The subsurf modifier is making this visible at the current settings. If I increase the subsurf to 3 or more the creasing is less but that is probably not a good permanent solution.

I think you will need to revisit the topology if you want better results.

I tried moving a few verts around and it helps some but I think you are going to need more geometry that follows the flow of the topology from the horizontal (torso) into the vertical (leg).