Strange Messages in DosBox ... What does they mean?


(Doc Holiday) #1

I one of my Projects (Aus die Maus!) i add and remove lot’s of Armatures with connected Meshes. With an AddObject-Actuator and EndObject-Actuators at the Armatures to kill it, incl. the connected Mesh. That works good, but …
I noticed, that the Game slows down, more and more as longer i work on it. Even i stop (ESC) and restart it §. But it seems this happens not every Time. It’s hard to explain.
After playing a while, and quitting Blender, i get such strange Stuff in the DosBox:

pose len: 24 04450A68
dupli_alloc len: 324 044500D0
dupli_alloc len: 324 04450C10
dupli_alloc len: 324 04450D88
dupli_alloc len: 324 0454B028
dupli_alloc len: 324 0454B1A0
dupli_alloc len: 324 0454B318
pose len: 24 0445EB90
dupli_alloc len: 324 04553C40
dupli_alloc len: 324 04553DB8
dupli_alloc len: 324 0454B490
dupli_alloc len: 324 0454B608
dupli_alloc len: 324 0454B780
dupli_alloc len: 324 0454B8F8
pose len: 24 0445EBD8
dupli_alloc len: 324 0447C028
dupli_alloc len: 324 0447C1A0
dupli_alloc len: 324 0447C318
dupli_alloc len: 324 0447C490
dupli_alloc len: 324 0447C608
dupli_alloc len: 324 0447C780

… and much more of this, as longer i’ve played. What does this mean?
Thanks for any Suggestion.
Doc


(NOR.J) #2

im not sure what it is, But i get this message some times when quitting blender, it all prints in a sec lol. But i havent noticed blender getting slower.
some guys said it had to do with some temp-files or somthing when i posted.


(z3r0 d) #3

blender has done this for a long time

I’ve noticed the slowdown

…I use it as another reason not to add or end armature deformed objects


(Doc Holiday) #4

So … locks i’ve to wait to 2.4. Maybe it is fixed. Otherwise i’ve to redo my whole Game. *#%$§!

Thanks
Doc


(LetterRip) #5

report it to the bug tracker, erwin is probably/hopefully going to look at the armature code for the 2.4 release so that issue might be addressed.

LetterRip