Strange object waviness seen in Render but not Layout view. What the heck?

Hiya folks. I am finishing up a tutorial that shows one how to make a raspberry using the new Geometry Nodes. I’m all set to render this out and ran into a weird problem. Here’s what it looks like in my Layout view:

But when I hit F12 to render it out it looks like this:

I'm baffled! Does anyone have an idea of how to get rid of the strange wavy/bumpy intersections?

Hi, I think it’s your camera clipping planes being too far apart. Not entirely sure.

I didn’t my camera had clipping planes! I’ll look into it, thanks.

Any other theories?

Hmmm…I found the clipping adjustments and messed with them to no avail. Thanks anyway Hadriscus

What renderer are you using ? Have you noticed the arrangement of the drupelets is also different between viewport and render ? are you using the is viewport node ? it would be helpful to see a comparison from the exact same angle. Right now your viewport is set to orthographic it seems.

1 Like

Thanks for being botanically accurate!

1 Like

Do you have a subdivision modifier on your drupelet object? Do the render and viewport settings match? It looks like there are more polys in the viewport version.

@SterlingRoth Your comment about subdivision modifier on the drupelet object was the clue I needed to solve this. I did indeed have subdivision modifier on it but I had not applied it. So I simply hit the “Apply” option and that fixed it. Yay.

Thanks to you and @Hadriscus for your efforts.