Strange "Pausing" Issue While Rotating


I have a weird issue which I am hoping someone will know the answer to.
I am using a Gigabyte Aero laptop (i7-9750 CPU, 32GB RAM, Geoforce RTX 2080 Max-Q)
I also have a 27 inch LG 4K monitor attached.
I use Blender on the external monitor.

If I rotate anything (even default cube) in Blender while the Windows desktop is showing on the laptop then there is a stutter in the rotation every few seconds. If I change it so the laptop is showing Firefox or Outlook then the stutter goes away completely.
I have set my desktop background to pure black, but still the same issue occurs.

Any ideas why this might be ?


  1. Set Max Performance in Windows (in Power Management).
  2. Update nVidia Drivers.
  3. nVidia Control Panel → 3D settings → Power Management → Max Performance.

    “Max-Q” means lower perfomance = low power gpu.

Hi @baldperv

Thanks for your response.

I’d tried numbers 1 and 2 already (in fact I already had those set)
I just tried the third possibility you gave and it’s the same.
I understand what you are saying about the GPU but I would not have expected a black windows desktop to have this effect when I can be displaying another copy of Blender on the laptop screen and when I rotate on the LG, it’s totally smooth.
Did that make any sense ?


I know about some delay and slowdowns when gpu changes P-states (Power States) from P8 (low power = slowest mode) to P0 (max power = max perfomance) and in nVidia Control Panel should be P0 (or P8 or whatever just no switching from one power mode to another) for Blender always.
I’m using “nvidiaInspector” and “nvidiaProfileInspector” for this.

You can force assign p-state overall for all tasks WITHOUT! driver auto detect power state. Create shortcuts (or .bat-files) with forcepstate-options in nvidiaInspector.exe folder:
-forcepstate:0.8 → for slowest and lets say “power safe mode” - P8
-forcepstate:0.0 → full throttle (max power) - P0
-forcepstate:0.16 → back to auto (default)

I have multi-monitor setup and no similar problems. Maybe you should play with multi-monitor settings in nvidiaProfileInspector.

Are you starting default Blender?
(delete “userpref.blend” from here C:\Users\username\AppData\Roaming\Blender Foundation\Blender\blender version\config)

Delete “nvdrssel.bin” from here - C:\ProgramData\NVIDIA Corporation\Drs

Hi @baldperv
Thank you for the suggestions.
I am using a modified default. My changes are minimal to the original default - just tweaking things to make them how I like it. I’ll back up those files (so I can reset it to what I like) and then delete them and give it another go.
I’ll also investigate the nvidiaInspector stuff.
I’ll report back.

Hi @baldperv
I am now totally confused.
I changed some of the performance settings in “Advanced System Settings” to try and get rid of another problem I have been having with Windows (top part of maximised window is missing in certain programs on external monitor)
I turned off “Animate windows when minimising and maximising” and “Show window contents while dragging” and suddenly Blender rotation is not stuttering any more. I really wasn’t expecting that to happen !
Windows is bonkers !