strange pixilated effect with tangent shading

Ive been having some trouble figuring out the tangent shading option for materials because every time i render it i get a strange black edge along the shaded portion of my sphere. I unwrapped it as a cylinder and as a sphere also but it keeps doing it.

If you’re using Buffershadow you could try to crank up the bias setting in the Shadow and Spot Panel.(Perhaps more SampleBuffers as well).
If you’re using Raytraceshadows you could play with the Soft Size and Samples setting in the Shadow and Spot Panel and additional with the Bias setting in the ShadersPanel of the objects Material.
This way you can get better results.

Another simple Approach would be to add a dark lamp in the shadow or a hemi light, to make shure the shadow gets at least a bit of light, to work with.


aha i figured it out don’t use ray shadows when tangent shading!

it must be a bug.
i got this ,too.