Strange rotation in particle system.

I am trying to learn about particle systems and I created the following test:

  • Create new scene, scale the default cube down to about 25% its original sizes0.25.
  • Add a mesh plane to the scene and rotate it slightly along the Y axis so it tilts to the side.
  • Add a particle system to the plane with the following settings:
  • Number of particles: 20
  • Particles per face: 1
  • Velocity Normal: 10.0
  • Set the Render option to Object and set the Dupli Object to the cube.
  • Set the size of the render object to 1.0


When I press Ctrl-A to run the simulation, the cubes are emitted from the plane at a rate of 1 every 10 frames (as I wanted) and they are not rotating.

If I let the simulation run past the last frame (default 250) and let it begin again, suddenly, the cubes are rotating as they are emitted. And if I stop the simulation and restart it, the cubes will continue to rotate as they are emitted.

UNLESS: I make a change to the particle system (change number of particles, or some other setting). Then when the simulation is started, the cubes will again start out not rotating as they are emitted until the animation passes the last frame and restarts, whereupon they begin rotating again.

Can anyone explain this behavior?

I am using Blender 2.69 r60995 on Windows 7, 64 Bit.


particles_test.blend (503 KB)

Open up the Cache tab under your Particle Settings and slide Cache Steps all the way down to 1 instead of 10. I’m not sure why 10 is the default, but it makes particles interpolate between baked frames strangely.

Thanks for the answer. Changing Cache Steps to 1 resolved the issue. I still wonder if this is intended behavior, a misunderstanding on my part, or if it is a bug.

This gets me every time and many particles tutorials have to point this out also. Lukas Tonne, if you are reading this, please consider changing Blender particles to have a default step size of 1