Strange shadow artifacts are appearing

Normals are fine. Mesh is triangulated. Surface is flat.
(these are the most common answers to that problem, but not in my case)
You can see it at the screenshot below.



Picture: object mode above, edit mode below.

You can see that the inner (smaller) cylinders have less faces, and the outer cylinder (larger) has twice as much (I did subdivide it). I can assume it is relaed to that subdivision. I have made subdivision (selecter upper and lower edge of cylinder and pressed W - Subdivision), then selected new edges and scaled them on X and Y axis on 1.05 (or on some similar multiplier).

What can this problem be caused by?

Best regards.

It seems that smooth shading is fighting with your triangulation. May I ask why your mesh is triangulated like that (rather than remaining all quads)?

As for a solution, let’s run through the simple things first:

  • Make sure you don’t have any doubled-up vertices (Select all, W > Remove Doubles)
  • Verify that the problem goes away when using flat shading (Select all, W > Shade Flat)… go back to smooth shading after
  • Try to change your triangles to quads (Select all, Alt+J). This may give you funky geometry that you might need to fix manually… but it may also not fully fix the problem.

It may be that none of those things fixes the issue for you. If that’s the case, then I’d suggest adding an Edge Split modifier or a Bevel modifier to your model, depending on what the finished thing is supposed to look like (and where you intend on using it).

Smooth shading over high angle edges or stored custom normals.

Thank you for your replies!
You are right. The smooth shading is at fault.
While this topic was being moderated, I have disabled Auto Smooth (Object - Normals - Auto Smooth) and it helped.

I did triangulate the mesh to use it in game as (as far as I understand) it will be triangulated by the game anyway. Are there times when using not triangulated objects in game will not use more resources (for the game to triangulate it)?
In this case even dissolving faces and trying to remove sharp angles, making Subdivision by Multiresolution modifier will still leave an issue if Auto Smooth is enabled.

Concerning solution, I am fine with Auto Smooth disabled, but did try to…

  1. Remove Doubles. Has 0 vertices.
  2. Use flat shading. Flat shading still have an issue, even more distinct on triangle edges.
  3. Before creating the topic I have tried to Dissolve Faces, it did not help even when there was only two faces left, they were shaded strangely.

I still do not understand why exactly this is happening (sharp angles are probably related, but…), but it does not puzzle me as much since I have found the solution (:

Thank you for the replies again.
Best regards.