Strange Shadows with the normal map


I am currently working on a project and i am using normal mapping.
But when I use it, the shadows are wrong when the image is set on “non-color”. However, the shadows are right when it is set on “sRGB”.

I want to export the file to Unity, this is why I need the normal map to work.

Any ideas of how I can fix this ?

(Here the result when it is set on “non-image”

First off, welcome to the community, @Munjii! I think I understand your question, but I think you already figured out your answer. According to the manual, the color input of the Normal Map node expects to receive RGB color data from your image input node. See here:

The Bump node generates normals based off a height map that uses non-color data. Maybe that is what you are thinking. Is there something specific about Unity that would require you to use a bump node rather than a Normal Map node?


How did You made that Normal Map? Did You baked it inside Blender? If Yes, then you might have saved it wrong (with wrong color space).

Hi, might help, but some other softwares that use directx have different ways of interpreting normals, so depending on where you got it (online or some settings when exporting in texturing softwares), you may need to invert the green channel of your normal map with a separate rgb node, an invert node and a combine rgb node. Hope this helps :).