Strange surface normals, how do I recalculate?

I converted a model to *.obj and imported in blender, but the surface normals are all weird.

  • Recalculating or flipping normals does not work.
  • Looking at the “vertex-per-face” normals I see that the normals seem aligned parallel with the surface!
  • One thing I’ve had succes with is sculpting the object with retopology on and zero strength. This fixes the normals, but the topology is messed up.
  • Setting vertex normals from faces makes the mesh look like smooth shading is turned on. Toggling between smooth and sharp returns (more or less) to the initial problem.



Attaching an example in case anyone want to have a look themselves.
strange_mesh.blend (522 KB)

Very odd, I am not sure. Sorry that’s not helpful, but I tried :slight_smile:


Not totally sure what the command does, but when unchecked (it is checked in your file) the problem seems to go away.

1 Like

Wow, totally took care of it. I’ve never heard of ‘auto smooth’ before, but I must have turned it on by mistake.
Thank you very much! Blendering went from frustrating to fun again :smiley:

Sure thing. I’ve never heard of or used it intentionally before either. I think the majority of what I know how to do in Blender started with just clicking random stuff anyways!

Enjoy!