Strange texture rendering problem with mipmapping off?

Heya I am encountering a strange problem. Textures (mipmapping is off) are being “broken up into chunks” and I can see each “chunk” being drawn. It creates an effect as though a seamless texture isn’t perfectly seamless.

Here is a video:

You can see the effect at the bottom left of the ground (if the thing actually uploads in decent quality).

Is there a specific cause to this?

Thanks :slight_smile:

EDIT: I thought the problem might be non-power-of-two texture sizes, but the same thing happens with them.

I have no idea what I should be looking at in the video O.o

Is there a seam in polygon structure there? Have you tried disabling filters? Have you tried with multiple resolutions and anti-aliasing?

It’s hard to explain. You have to look carefully at the big plane. Notice some kind of artifacts in the texture… Try watch it in HD.

What I do see is I think about camera micro movement resulting in annoying sampling of pixel colors but that affects everything you have in your scene. The ground texture only has enough contrast to make it noticeable and irritating.

Try increasing the resolution, enabling AA or fixing that camera movement?

Increasing resolution made the chunks bigger, which I suppose is slightly better. Anti-aliasing didn’t fix it. The camera movement is an idle animation.

I don’t see the effect that you’re mentioning on a specific part of the ground, but I do see the slight “shuffley pixels” look because of the camera’s idle animation. What you might want to do is lock the camera’s actual (drawing) position to whole pixel positions.

I see some blocky distortion artifacts. These happen because the texture pixels are not aligned with the screen pixels. The width of each texture pixel on the screen is not a perfect multiple of the width of each screen pixel, so sampling artifacts occur. The only way to fix it is to carefully adjust the scaling of the floor object so that texture pixel width is an exact multiple of screen pixel width. Unfortunately, even if you get it perfect, if you try to play the game at a different screen resolution, it will get screwed up again.

It’s an inherent drawback with point-sampled texture filtering. The only true fix is to enable mipmapping.

Ah that makes perfect sense… And… Yeah I’m bad at explaining stuff… lol

Guess I’ll have to just deal with the problem, or maybe fix it with motion blur :slight_smile: Thanks for the help.