Strange :/

I have a problem - i have an empty and a plane , the empty is a parent of the plane.I have it set up so that when the plane collides with some other object , it makes the empty move(dloc).However the collition is only detected when not the plane itself collides , but it’s center , but when i unparent the plane and the empty , everything i ok.Can you people tell me whats the problem (i hope it doesnt mean that if a obj is a child , the collition detection only happens when the center of the object collides - it should be colliding with the faces not the center of the object(i use 2.36 , but in my very first game(made with 2.34) the collition detection was working properly)).

Maybe its a bug :-?

I’ve tried it. But all looking fine here. (Win2k 2.36) Hm, really strange. :-? Do You have a small Example File, or a Screenshot?

Never mind , it suddenly started working the right way when i changed my script(it was probably my script that messed it up , dont know why though).But thanks for replying anyways Doc :smiley: (atleas now i know its not blenders fault).

Damn , now it reapeared , what tha fk is it.Now it happens with out the script.I have an empty , a child empty(with rotation ipo) , and a meshed object , which is a child of the empty with ipo.When the meshed object collides with something , the parent empty (the one without the ipo) moves(dloc).But that doesnt happen .It even seems like the meshed object doesnt even exist - it doesnt add objects(well , it might be adding, because framerate drops,but something is definetaly not fking right,cause the object thats added isnt visible too) , other objects cant detect it with a near sensor(not even with the maximum distance).Completly nothing works :x :x :x :x :x :x :x :x :x :x :x :x :x :x :x :x :x :x :x .What is going On :< :< :< :< :< :< :< :< :< :< :< .This bug is ruining EVERYTHING(and my game was going so great :frowning: ).Please help me (i could send someone an example - cube is a child of empty with ipo which loops,the cube collides with a plane , the plane is supposed to rotate when that happens, and yes i do have collision faces enabled).

Please help!

I guess noone knows the solution.Thats sad.(one of my unluckyest days).All the three-months-long work is lost now because of this stupid god damn s**t bug.Sorry about the language , its just that im really mad right now.

i would like to help but need to see the problem first hand and the link you provided doesn’t seem to be working %|

Strange , the link seems to be working to me(i downloaded it myself).Could anyone please host it just for a little while, so others could see the problem.
I could send it to someone by e-mail.

People , i solved the problem :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: .The problem was i was scaling the emptys down(i thought you could do the apply size and rotation thingy to emptys too.So when i scaled the empty down the child objects collision mesh scaled down too.LOLOLOLOLOL , how could ive been so damn stupid , emptys dont have meshes so you cant do the apply size and rotation thingy.Damn im so happy its not blender’s bug :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: .My game is saved , yeeeeeeeeehaaaaaaaaaaaaaaaaaaaa!!!

I also had this problem once. Thanks for figuring that out.