Stream Tool

Thank you.
@bnzs I’m afraid it’s too difficult for me. I just started to learn how to program. And the author of the Batch Transforms is something like my patron. If it were not for @ dairin0d, I would have managed to navigate this and with this.

It would be perfect if you can solve the calling twice error pop up other than that it works quite nicely :slight_smile:

Stream Quick Set Pivot v0.2
Fix BVHTree in edit mode
Fix return meshs elect mode(vertex, edge, face)
Bad fix calling twice

Stream Quick Set Pivot v0.3
Fix: work with modifiers

Great job no more error messages works like a charm :stuck_out_tongue:

Snap view(It looks like zbrush)
Default hotkey alt+left mouse(maya)

use:
Press shift and release left mouse

When I activate this, I see ‘Error (see console)’, but there’s no error in the console…

@Mighty Pea
This is normal. I tried to configure the hotkeys in addon preferences. But it did not work.
This error does not affect how the addon works

Love the snapping at the center of edge and faces part !

This addon still in development. He does not fall but does not work as I wanted. The benchmark for me is Softimage XSI

You say that it doesn’t affect how the addon works, but: it doesn’t work for me.
It’s also confusing that you say alt-lmb is the default hotkey, but… you have to release shift to get it to work?

Perhaps it is necessary
Disable standard hotkey

Thanks for sharing

That’s my key to rotate the viewport, but disabling it (as you’d expect) just makes it so I can’t rotate the view at all.

Ah, I see now. I don’t get any feedback. I have to release the mouse button, and if I’m in the right position it’ll then go into Ortho. Would it be possible to get realtime feedback as with the regular alt-snapping that rotate.view does?

Unfortunately no. I tried to do in realtime, but there arises problemma with auto perspective. I think I will return to this issue in the future. Now there is a lot of work and there is absolutely no time

New tool. Select loop edges between a seam edges

https://drive.google.com/open?id=1wrs7PZY1uLVK_t8p-7Rgwl_ezvKZJxbV

ONLY MAYA NAVIGATION
StreamSnapView fix for blender 2.79

Thank you very much for these great tools, I especially like the “Quick Set Pivot” one, however it doesn’t seem to work on isolated objects. Local view that is.

edit:

I keep also getting this error message in Object as well as Edit mode


Snap View update

suport all naigation

For blender Ctrl
For Maya and 3DS Max Shift