stretched uv texture

i have this model I’m working on and im having a problem with the texture application.

the area circled in red in the image shows how the texture is stretching over this particular area. i have had this happen in the past and have always just gone and edited the uv to make the faces a little longer to correct for the stretched area. in this particular model, however, i cannot seem to get rid of the stretch. it doesnt seem to matter which way i arrange the faces in the uv editor, this one area always stretches out the same way. ( there are other areas in the model that are stretched also but this is the most apparent and the one I’m having the most trouble with) could anyone offer me any suggestions that might get me past this?

ive tried the minimize stretch function in the uv editor, ive made new uv maps, tried different projections, ive even tried rebuilding that particular portion of the model just in case.

so, like i said, ive had this issue before but have always been able to solve it but this time its as though its frozen in this uv layout or something.


You seemed to have forgotten to attach/link to your blend file, which would have all textures packed in it, so other users can see what you are able to see

it’s not that ive forgotten, but that I’m unable. the .blend is only 7.5mb but i get an error on upload that says upload failed with no explanation of what the problem might be.

Google Drive / Dropbox / SkyDrive / etc or http://www.pasteall.org/blend/

ahh, yes. how foolish of me.

https://dl.dropbox.com/u/11358414/spa.blend

The material has two textures, Marble.001 and Marble.002, the first is mapped to the UVs (correct) and the latter is mapped to Generated (wrong). Textures are applied from top to bottom in the texture stack so the Marble.002 mapped to generated coordinates is actually overlayed on top of the correct texture. Disable/Delete Marble.002.

EDIT: You will also need to take into account the stretching of the mesh when you have the subsurf modifier. When you unwrap (U / unwrap) there is an option in the toolshelf to take this into account (Use Subsurf Data). Otherwise you will have to add addition edge loops or add creasing on those edges. You would lose some rounding of your object so you may also have to just manually adjust the unwrapped faces in the UV/Imgae editor

The images show the stretching at the edge with the modifier on and no stretching with the modifier off

Attachments




Holy crap. I can’t believe that’s the issue. I’ve been trying to figure this out for hours and hours. I’ve used this same model for a number of renditions now. I guess I just wasn’t paying attention. Thanks very much for your eagle eye!