Stripes / noise on rendered faces

I’m pretty new to Blender and one thing is making me tear out my hair! When I render what should be a simple flat surface, it ends up with stripes all over it:


The meshes for the objects are pretty simple, just subdivided cubes:


I have tried Recalculate Normals Outside but it doesn’t help. I saw in another thread (which I’m damned if I can find now!) where somebody suggested about three different things to try to cure this striping problem - one of which was Recalculate Normals…which doesn’t help.

Please can anyone suggest what else might cure this problem? I’ve spent hours remodelling the same objects various ways but the same thing always happens!

You’ve probably already tried this, but have you entered Edit mode, selected all the verticies with AKey, and used the mesh tool panel to remove duplicates?

I am thinking it looks like your texture, how many times is the texture repeated across the model?

Yep, I’ve tried a Remove Doubles, but it doesn’t find any.

As for the texture, I don’t know how many times it’s repeated across the model - is that something to do with the sizeX, sizeY and sizeZ options in the Map Input box? If so, I tried changing these from their default 1 to firstly 5, then 50, but the render still looks exactly the same.

Incidentally, as a test, I added a standard cube sitting on top of the affected objects. I gave the cube a different (smooth) material type that has no texture. The cube also renders with stripes:


What’s going on?

Can you upload the blend file that we can see the complete settings of your scene?
This looks really strange.

Are you using buffered shadows? If so, first make sure your clipping distances are optimised (just enough to cover your objects) then try tweaking the bias.

Wahoo! :slight_smile:

Many thanks for your help, problem solved! It was indeed the ‘Buf. Shadow’ setting that was the problem. Setting all my lamps to ‘Ray Shadow’ immediately removed the stripes. Since I don’t know what the difference is, perhaps it’s time I hit the tutorials again… :wink:

Wow, glad to hear that this is solved, I did not know about the buf shadow problem… Interesting.

Reaction: I’d recommend you do that - Although Raytraced shadows can be simpler, they also take a lot longer to render, and can be less controllable. Getting used to buffer shadows (and tweaking them with bias etc) is a valuable skill to learn.

cheers

I’d personally use the ray shadows of arealights, you can change the square size (scene scale matters), to make them softer the farther they go.

I’ll definitely investigate buffer shadows further. I tried using them again, this time setting the clipping distance vey carefully, but it made little if any difference. However, I forgot to try the Bias setting though, so perhaps that will be the key.