"Stripes" on the object surfaces in viewport

Getting some “stripes” on objects both in Solid and Material viewport modes (2.79):

Must be something to do with my GPU but are there any settings to get this problem less pronounced?

Could be many things…
Would you care to post a file with a part from the scene showing an issue?

I think I’ve pinned it down to a somewhat weird work of screenspace AO.

Nice, so it’s fine - mark thread as SOLVED