stucked rendering in array test: SOLVED!


Got again a little worry… I’m in testing array animations with 1 object having transparencies and the other having softbodies.
Since approximately 3/4 of an hour the rendered image stays at the same stage with apparently half of the attributed CPUs used at full capacity (3-4 of them on 8).
Here where it stukes:

And here is the f10 Panel:

There might be something wrong with my material, perhaps? Here it is:

What could it be?

PS In fact, it’s not totally stoped: a tiny little stripe has been rendered these last 20 minutes!
PPS Actually the array “point” is containing 49 arrayed copies of the same object… hum…

Rectification: render has completed the first frame (of 500) in exactly 3hours 16 minutes 41.46 sec !!
No other choice then testing with a really basic material, i guess…
What’s your take?

Can you upload a .blend?

Here Hobo Joe:

Thanks to spare some time for a look… In the meantime, i just leave it render for a night to see how it evolves (it works in background therefore i will make the changes only tomorrow)

Well, you have over 1 million vertices, for starters. And a large amount of those are hidden away in high subsurf numbers and array instances. The first thing I did was completely get rid of subsurf on the sphere, and turn the subsurf on the softbody object to 1. Then I separated everything into layers.

The main object on layer one, the sphere on layer 2, and the softbody object on layer 3. And the lamp and the camera on all 3 layers.

The sphere rendered in about 10 seconds, so that wasn’t what was slowing things down. The softbody object rendered in about 30 seconds.(with the entire array visable in the camera). The main array rendered in about 3 minutes.
When I mixed the first and second layers though, the render time went through the roof, and it took 5 minutes at least to render 2 of the 64 parts. When i turned off raytracing, though, it went down to 14 seconds for the entire frame. The problem is that it doesn’t look near as good when you have raytracing off.

One thing that would really help rendering speeds would be to leave the softbody layer out of the render until it comes on screen. Even if it’s not on screen, all the extra polys will slow down your render. Keep it on another layer until you get to the point where it comes on screen, only then should you render the layer it’s on.

Also, I noticed that you had ‘threads’ set to 8. Do you really have 8 cores?

It looks like you’ll have to live with pretty high render times, sadly, unless you’re willing to give up the raytracing. However, it should still be significantly less than it was after removing subsurf and everything.


I’ve had a play with this file too. As well as removing the subsurf, I’ve replaced your sun with a spot light at a distance. You can get decent render times with buffered shadows.

Hey! Nice you took time for a look!

  1. I have no experience at all with layers and will use it more right away after what was written here!
  2. It seamed that without subsurfing the sphere, the material would look pixelized… might go down to 1 with it yet (edit: comes out nice too).
  3. I have passepartout ON… i thought it was ment to have only the vertices included in camera view to be rendered (some apps have this funtion - even Carrara)
  4. There are 8 cores
  5. There are always other apps used while rendering is in background task… So around 30 - 50 % slow down must be taken in account.
  6. Ambiant Occlusion was and is still ON
  7. Save Buffer was and is still ON
  8. Depending on next result, i’ll make a try with SPOT LIGHT instead of sun(have only to make sure diffuse will be large enough).

Notice 1: frames where the array has separated the intanced objects are rendered much faster (about 20 min/frame)
Notice 2: the scene MUST be “real” 3D. No postcompositing allowed.

Actually, it’s running a copy of the file on Blender246_3rd installed app to watch the difference with the first render (still went on to frame 6 -afternoon and overnight rendering - with a 3 hours per frame output). I’ve put the softbodies on another layer (disabled the layer for render) and lowed the sphere subsurf to 1.
Latest result for frame 1 is: 2:45:02.68

Result with rawpigeons corrected file (same frame): 00:00:13.62 !!!

Got to analyse what you’ve done to it man! Gosh!! Seams impossible!!!

Great thanks guys! This is a uge help you’re giving me here!


In fact, you just changed from raytrace to buf.shadow with replacing the sun by a spotlight and here it goes?!
Nothing else?
This is completely flabbergasting me! Can’t believe it!

I applied what i observed in your changes and get the same frame in 4 minutes on my original file, verso 13.62 with yours… But with my render it all starts with “filling Octree” and the material doesn’t get the same aspect… So i get to find out the best of these two worlds :wink:

Also, i will have to loose my habit of systematically render in raytrace… maybe not that necessary in many of my futur animations…

As far as I know filling the Octree does not use multithreading and there for cannot use all of your 8 cores. Same goes for AO in case you are using it.
Also try playing around with the resolution of the octree it is the little drop down next to sky,premul,key.

Hum! How can i know if and when filling octree is of any use?
Strange thing: rawpigeon has left it to 128 as it is in my original file too… Why does this octree filling start on mine and not on the other?
Wonder how i could have it as straight as rawpigeon’s arrnaged file…?

EDIT: Gosh! Pulled octree to 256 and de render is almost 4x faster on my file! … but it takes the render of rawpigeon’s to 14.1 instead of 13.62.
And NOW with octree on 512 it took 12.02 on raw’s copy and 33.50 sec on mine (45.08 with SSS on) ?!? So there must be something else going on in the guts of it…
Well! 45 seconds verso 3 hours… i can rather be glad enough! Don’t you all think so :wink: :wink:

I love you folks!!


I’d disabled raytracing and SSS because they didn’t seem to make much visible difference in the frame I was looking at, but 45 seconds sounds more than acceptable for that extra detail.

Glad you got it working nicely :slight_smile:

Yes, thanks again! It rendered fine over 500 frames within few hours! :wink:
I have yet a lot of work to get it to more esthetics… but at that pace it’s no problem anymore!

I can happily close this thread with: SOLVED! :wink: