Studding the Inside of an Arch

I am trying to line the inside of an arch with nozzle-like meshes. I tried using duplifaces, but the nozzles that resulted were deformed. Is there any way to do that, modifying only location and rotation and not scale?

Thanks,

Skyler

can you show a pic of it
would be easier to see adn then help you

Thanks

True. Here’s the Blender screen:

And a render of what I get:

Notice how the “nozzles” get flatter towards the bottom of the arch.

are theses dogtooth motif from old architecture style
i mean classical architecture

i did some but i had to set them one by one unless it’s a circular arch
like in gothic arches
if it is circular you could use the array modifier

Salutations

Is it because the faces get longer towards the bottom of the arch?

Organic–I suspect that is most likely the case.

And ricky, no, they’re focusing adapters for high-energy verteron particles. I’m trying to make a wormhole-based weapon deploying system.

Hay this is the same problem that I’ve been having. (only I’m trying to put on rivets for metal plating.)
The only thing that has been somewhat working for me is to duplicate along a curve. But I’m limited to having them equally spaced apart. (which isn’t necessarily bad for my current purpose) However, it is really hard to get them to align accurately with my faces, is there a better or faster way of doing this? I’m working with a lot of rivets so hand placing them isn’t really ideal.

Skyler, see if the duplicate along path works for you: just add the array, and curve modifiers to the beam focuser thing and a curve that follows the geometry of the arch.

Apply scale on the arch object (ctrl-a) At the moment you have it scaled along the z axis, so all the duplis are scaled too.

Hey ben,

I have just tried that and unfortunately it had no effect. I tried creating a new arch and that didn’t help either. The duplis are still squashed in the same way.

OK, tried the duplicate along curve too; it’s giving me the same squashed look. I tried applying scale on that and had no better luck.

Did you scale the arch or the object before or after enabling Duplifaces?
Did you apply CTRL+A to the arch or the dupli object?

  1. Unparent the object from the arch.
  2. Apply scale/rotation to the arch.
  3. Apply scale/rotation to the object.
  4. Reparent the object to the arch.

Organic: I scaled the arch, then applied the scale on the arch, then parented the object to it and enabled duplifaces. Now, I’ve just tried again, this time applying scale on the object as well, and it works perfectly. Thank you for your help.