Stupid wall!


(blendermani) #1

:frowning: I have a little problem: I have created a game. It totally worked except the thing that I can walk through walls for example. How do I solve that?

Besides does anyone know how to convert a *.midi file to a *.wav file?


(S68) #2

I’m not a game expert, but I think you should enable ACTOR and DYNAMIC on your character and set ‘Size’ to a convenient dimension so that the sphere for collisoin detections completely encloses the character.

Stefano


(blendermani) #3

I already had those two things enabled on the main character and sized the sphere to the good size (a long time ago), but it still happened.


(digitalSlav) #4

make sure all normals are on the side of the wall you are trying to block from… disable double sided from geometry that doesn’t need to be double sided as well… still with all this i found flaws in this area. to solve these problems instead of using “planes” (not really planes but single pieces of poly) for walls i made cubes for the walls or if making a room extrude the cube and size a little bigger to give the outer wall more density. for some reason this seemed to work for me. give it a try :wink:


(blendermani) #5

Thanks!
:smiley: