Stupid Wind!

ok…so im making a little animation and i want a stupid flag in it but i put wind on some random plane and the wind wont work…maybe imm doind somehting wrong…heres my setup…(the flags not actually green it has a texture

Attachments


You need to make the flags softbodies. Here is some useful info. http://wiki.blender.org/index.php/BSoD/Physical_Simulation/Soft_Body#Simulating_a_flag_in_a_pole

im made it a cloth…i have 2.46

idk maybe look for cloth tutorials on the wiki? cloth intro

Hi,

Have you given your wind some strength?

Have you set the edges to be affected by wind?

ive given wind strengh and how do u do the edges thing?

You have to enable aero or whats it called…

when i press “alt a” my blender freezes at frame 2… the i have to close it by the console window… then i have to send some random error report :(… so now I’m actually animating it and ill let it sit for about an hour and see what happens…thanks for all the help

blender spartan

Wow - good luck with project!

lol…thanks :stuck_out_tongue:

Don’t use the softbodies, use cloth instead.

Be sure to weight paint the areas (red) that you want to stay in place (like the corners of the flag). After doing your weight painting, look at the group name, and name it if you want.

Go to the cloth panel (with your flag selected).

Make sure Pinning of Cloth is enabled and the right group name shows up.

Create an empty and set it as a wind object in the Physics Panel. For ease of reference for now, look to see if it is set to tube (it might be cone). Set a powerful strength at first for testing.

Rotate the wind object so the Z axis is pointing at your flag mesh. Be sure to look at the different viewports to ensure that you get the correct Z positioning. Once this is done, be sure to save your project.

With your flag mesh selected, go back to the cloth panel and under the Collision tab, make sure your start and end frames match up with your animation total number of frames for the project.

While you are in the cloth panel, click on Bake. You should then see it starting to run. Let it run until it finishes. When done, SAVE your project again.

Now do a Alt-A. Once again, don’t use the softbodies feature, it’s waaaaaaay too slow.

Also, make sure your flag is subdivided enough and the set smooth option is on in the editing panel. Hope this helps. If I made a mistake in any of this, let me know ok.

You can make changes to the wind object as far as strength and noise factor. After doing so you will need to Bake again. Be sure you are always at the starting frame when you bake.