Stuttering video

I’m using Blender (2.70a) on Windows 7 (Home Premium 64 bit) and I have a very simple, short scene that’s stuttering on playback (VLC 2.1.5 or Quicktime 7.7.5) http://www.pasteall.org/blend/30912
It’s being rendered to h.264 in 1920 x 1080 @ 30fps.

I tried using Handbrake, from this post: http://www.elysiun.com/forum/showthread.php?305702-How-to-get-a-smoothly-animated-video-rendered

(render to AVI raw with Blender then encode to h264 using Handbrake) but it didn’t work, the video is still stuttering. I also tried setting the bit-rate to 10,000 or higher and min and max bit-rate to the same thing.

I have a laptop with not a lot of power (see below) but I can watch the Youtube video referenced earlier in that thread or download and watch it with VLC 2.1.5 with no stuttering. http://www.youtube.com/watch?feature…&v=1BkYrQt_U_E

HP Laptop: Pavilion DM3
AMD Athlon Neo X2 Dual core Processor L335, 1.6 GHZ
4 gig ram, 320gb HDD
ATI Radeon HD 3200
Windows 7 home premium (64 bit)

Why are you rendering to something like AVI Raw especially give a pretty low powered machine.

What result do you get rendering directly to H264 or to an image sequence

The attached was your file rendered directly from blender as H264. How does it play in VLC ?

Attachments

circle10001-0050.avi.zip (32.2 KB)

Why are you rendering to something like AVI Raw especially give a pretty low powered machine.

User Hamburger TS in the thread I mentioned did it because he had the same stuttering problem. He then used Handbrake to encode to h.264.

What result do you get rendering directly to H264 or to an image sequence

As I mentioned, the video stutters.

The attached was your file rendered directly from blender as H264. How does it play in VLC ?

That’s what I tried originally, but the video stutters.

I think you’re going to need to show us something. I don’t know what you mean by, “stuttering,” and I’m not sure that you knew what Richard meant by “rendering to an image sequence.”

What I’d suggest that you do is to change the initial rendering-output format to, say, PNG … which will create a series of individual files, one per frame, in the chosen output-directory. You can then play-back that animation or look at it frame-by-frame to see, and to see closely, exactly what Blender did.

Then, use another Blend file and the VSE, with one image-strip corresponding to the entire set of individual PNGs. Use this to generate an output file in movie-format. If you play it back in Blender, you can see if “dropped frames” are occurring. Since you are now drawing from a set of files that have already been completely rendered, you can “tweak” the settings for generating the movie-file and regenerate the movie-file rapidly.

“Stuttering” can mean lots of things … including, as in the thread that you referred-to, the need for motion-blur. It can also be caused by video-compression artifacts. Your description really doesn’t point to an explanation for what you’re seeing; nor, therefore, an actionable solution.

  1. By “stuttering” I mean the same as Hamburger TS explained it:
    “The object is not sliding but “stepping” and “flicker” through the scene…”

  2. " I’m not sure that you knew what Richard meant by “rendering to an image sequence.” "
    Yes, I understand what an image sequence is. Under “Output” in the render settings I selected: “PNG” and rendered out the sequence. I then created a new scene and switched from “Default” to “Video Editor” then set my settings:
    1920 x 1080 @ 30 fps, 50% scale, preview window set to 1:1
    and imported the sequence to the Video Sequencer Editor (VSE) using Add-> Image “Add an image or image sequence to the sequencer” and played it back. It starts with 30 fps but slows to less then 1 fps !!

  3. Hamburger TS tried both motion blur and vector blur and said it didn’t help much. I tried motion blur (“Sampled Motion blur” under the render settings with; motion samples = 3, shutter = 0.25) a VERY slight improvement. I tried higher settings with no reasonable improvement.

I certainly did not mean to be insulting in my comment. Just sayin’ … :slight_smile:

Try using VSE to export the image-sequence to a single movie-file output. AVI or MOV or somesuch. Then, using maybe a completely different program, view that.

Obviously, obviously, if anything on a modern-day computer “slows to less than one frame per second,” when the only thing it’s supposed to be doing is gathering a bunch of PNG files off the hard-drive and rolling them in front of your eyeballs, then something “way out there in left field” must be desperately-wrong.

I hope someone else will chime-in on this thread to explain what might be causing such dramatic non-performance, and especially for things to grind to a halt. (If it starts out at 30 FPS, why can’t it just keep going? "Yeah, maybe with a little loss of speed, but … this, clearly, is ridiculous.)

Yes, my computer also isn’t big enough to do it when churning through OpenEXR files, because the disk isn’t fast enough, but it’s easy enough to render-out a movie file and then watch that.

Setting the image-size for that movie file to “a portion of screen-size” is also useful … smaller movies are faster, and it doesn’t matter because this movie-file is “for your eyes only.” It’s a throw-away output that’s being generated from a high-resolution data source. (Which, by the way, is always OpenEXR for me, not PNG.)

Are your disk-drives okay? Have you run diagnostic tests on them, looked at SMART (IDE internal self-test) reports of the data which the drives keep for and about themselves?

I’m still trying to solve this.

The problem: non-smooth “jerky” movement, some call it stuttering, juttering, etc. I’ve tried playback on both VLC 2.1.5 and Quicktime 7.7.5. VLC drops between 0 to 8 frames with 0 dropped frames occurring very infrequently.

My animation consists of a single flat circle (no depth), I want a 2D look. The circle is made of four sided polygons (256 faces total) and it’s size is 4 square blender units.

Frames Total: 105
Resolution: 1280 x 720 @ 30 fps, H.264.
Destination: Vimeo
Audio: None(yet)
Raytracing: None
Shading: Flat
Anti-Aliasing: Yes, 8 preset

The circle moves 5 blender units to the right in a straight line, beginning at frame 30 and ending at frame 75.

In the first 30 frames (1 sec) and the last 30 frames, the circle does not move. I’ve read that there are problems when an animation begins immediately so I’ve left this buffer where I intentionally have no movement.

What I’ve tried to fix the problem:

Various Bitrates: 5,000 to 10,000 kb/s
Setting Bitrate, min and max all to the same thing.
Various GOP sizes including 15 (half the frame rate)
Motion blur “Sampled Motion blur under the render settings”
User “Hamburger TS” tried vector blur as well.
Rendered to uncompressed AVI from Blender then imported it into Handbrake and rendering to H.264.
Rendered PNG sequence (no compression, 8 bit, RGB) from Blender then imported it to the VSE in Blender and rendered to H.264.
Rendered PNG sequence (no compression, 8 bit, RGB) from Blender then used the free version of Lightworks to render to “Web/Youtube” format.

Here is a link to:
Blender file
Zip folder containing all 105 images (8 bit RGB PNG’s).
The finished animation, which can also be downloaded.

https://drive.google.com/folderview?id=0B44GJKmFnPfaZ0NfcjBmTmpwVWs&usp=sharing

System Specs:
HP Laptop: Pavilion DM3
CPU: AMD Athlon Neo X2 Dual core Processor L335, 1.6 GHZ
Memory: 4 GB
HDD: 320GB sata
Graphics: ATI Radeon HD 3200
O.S. Windows 7 home premium (64 bit)

I can play other videos, that I’ve downloaded like this one, just fine:
http://www.youtube.com/watch?feature…&v=1BkYrQt_U_E