Sub surface modifier causing banding on my texture

Hello folks. I’m a pretty much a beginner at modelling in Blender and ran into this problem today: Adding sub-surf makes the edges of my texture look stretched. See screenshot. Cube on left has no sub-surf. Any tips?


The subsurf changes the position of the vertices which you haven’t taken of account of when you uv unwrapped

You can add additiona edge loops or edge creasing at the places where the distortion happens or use the ‘Use Subsurf Modifier’ option in the UV unwrap settings

Thank you Richard! Edge creasing worked perfectly!

I am curious about ‘Use Subsurf Modifier’ in UV unwrap. I don’t know where it is in the interface. Could you direct me to it?


I am curious about ‘Use Subsurf Modifier’ in UV unwrap. I don’t know where it is in the interface. Could you direct me to it?
After you press U / Unwrap, like all other tools in blender there are additional options in the operator panel (bottom of the toolshelf (T) or F6)

Found it. Thanks again!