Subdivision modifier changes shape

Hey there!
I’m new to blender, I started working on some headset modeling.
I started with a circle, added an inner radius, deleted the middle face and the vertices of the bottom half of the circle and extruded it to make a part of my headphone.

But the object merges at the center when I add a subdivision modifier.
What should I do to avoid this? Any help will be greatly appreciated.


After subdivision


before the subdivision modifier

If you attach a file, it will be much easier to find the problem :slight_smile:

2 Likes

Welcome to Blender Artists!

Have you checked that your normals are facing the correct direction?

Have you gone into edit mode, selected all vertices, pressed “m”, chosen “by distance” and chosen a very low number (like 0.00001) to get rid of any duplicate vertices and attach any parts that may not be attached?

Once you’ve done that, you’ll likely have to select any edges you want creased in edit mode and set the edge crease to 1.

If none of that works for you feel free to post a .blend file (if you can, I know new members can’t add attachments sometimes).

If this is all over your head it might be good to follow some hard surface modeling tutorials on youtube to get an idea of best practices and common problems, it can be really unintuitive and frustrating at first, but really satisfying once you get the hang of it.

1 Like

@Nanomanpro @nettleada
Once again, I really appreciate your concern :))
Yes, I did check the normals, tried adding creases, also got rid of the ngons, It didn’t work.

my blender file → https://drive.google.com/file/d/1-0YI4iSNdZGvXGigTJCDGEz5yWREQl9T/view?usp=sharing

Figured it out! The faces on the front and back were each just one big ngon rather than the individual quads that they appeared to be. I deleted the 2 ngon faces and replaced them with quads and then the subdivision modifier worked. untitled3_fixed.blend (992.2 KB)

2 Likes

Thank you soooo muchhh :>>>

1 Like