Subdivision preview mode missing?


(joelregefalk) #1

Hi guys! My first post here after being a Blender user for about a year. And what better reason is there to write on the forum when you’ve got a problem, right? :grinning:

When I apply the Subdivision modifier and go in to edit mode I should be able to see a see through model of the preview how it looks. I have the “Display modifier in Edit mode” applied, but still I don’t see the subdivided model. I’ve been trying everything on the overlays and googling the hell out of it but haven’t found a solution.

I know 2.8 is not fully developed, but I badly wanna start using 2.8, and I see people doing amazing stuff with Eevee and all the other features, so I would be grateful for help.

Preview won’t show in edit mode


(Michael W) #2

Nope. It’s just not been gotten around to yet. Patience! :wink:


(Piotr Adamowicz) #3

A moderator needs to put a big fat pinned reminder in this forum section that 2.8 is nowhere near ready and lots of stuff doesn’t work.


(joelregefalk) #4

Alright alright! Thanks guys!


(1832vin) #5

A moderator needs to put a big fat pinned reminder in this forum section that 2.8 is nowhere near ready and lots of stuff doesn’t work.

I think the problem is that everyone doesn’t know if something has just simply changed, or not made yet


(Ace Dragon) #6

The existing subsurf code is being ripped out and replaced with new code based on the OpenSubDiv library (which is becoming the industry-wide standard).

I would imagine stuff like visibility in editmode should follow.


(joelregefalk) #7

Let’s hope it will be in place when they release the beta, because right now that’s the only feature I really miss! :slight_smile:


(erickBlender) #8

Try to work on your faith, we are in Blender miracles do happen here :joy:


(Fonden) #9

I hate to reopen an old thread, but Is this still missing? I just started moving over to 2.8, and I have the latest build, but the “display in edit mode” option still doesn’t seem to work with the subdivision surface modifier. Is this still not implemented, or am I doing something wrong?

Thanks


(zeauro) #10

It should work in beta.


(Fonden) #11

Thanks for the reply. Turns out it was the scripts I was using, something happened with how Blender draws solid mode, and the mesh wasn’t showing correctly. So not a Blender bug!