Subdivision Surfaces Holes

Hey, I’m relatively new here in blender, and so far I’m learning alot. However; there’s only one problem I keep on getting whenever I use Subdivision Surfaces:

As you can see around the ring, there are wide triangle shaped holes. Apparently I’ve tried to see what was the problem by going into Wireframes and Space View, seeing if any edges and vertices were not connected, out of place, or unnecessary extra edges/vertices. So far I can’t seem to solve this problem whenever I’m trying to keep the ring fully attached onto the large cylinder when I use Subdivision Surfaces Modifier Levels to make the model much smoother. Any way to fix this problem?

Edit: Forgot to put in blend file: Rod.blend (590 KB)

Post the blend file,from the pic it looks like 2 edge loops are too close to each other.

Looks like you are using the SubDiv modifier without enabling the tiny dot-triangle. Also make sure you enable Smooth Shading when you exit Edit Mode. Happy blending!

[ATTACH]328178[/ATTACH] Here’s the model… I know I’m just beginning but I need help on this particular problem.


Rod.blend (590 KB)

I think i see triangles. Subsurf does not like triangles.
Post a blend file.

It’s still showing triangular holes, and when I enter object mode after I added smooth shading, I enter Subvision Surfaces once more and I tried to tweak the view and mass but it’s not doing any favors.

Lots of doubles and tri’s. Thats the issue.

All I did was box select this one loop and removed 175 verts using remove doubles. …I dont even know how thats possible…

Wait… that many vertices around that loop?! How did that happen?! Anyways, thanks for helping me fix with that situaion… but I have one more problem. How do I make the two loops on the center of the cylinder more rounded than jagged? I tried smoothing the surfaces and Subdivisioning everything, but they always come out as smooth yet edgy loops. Do I have to add more edges/vertices to the loops?

You have shape keys set. Remove those because you’re doing mesh edits. Object has unapplied and non-uniform scale. Object mode, ctrl+A -> scale to apply.

If you just removed doubles there are still edges left inside that connect two vertices over the desired shape. Remove those and the triangles and you get a smooth subdivision.

Oh nice nice! Thank you so much!

Umm, quick question though, how do you make the torus reappear? I tried everything but it’s still not showing it. It’s not marked invisible or anything, and it’s just weird.

I used local viewmode (numpad_/) to isolate the tube in the view and then switched back to normal viewmode afterwards. Same hotkey.

Hi, guys
I have a problem related to this thread (or I believe so), my blender issue is that when I try to apply subdivision function on 4 sides of the barn that I’m creating, only two sides are divided with cuts and on the another two sides (the long ones) only appear new vertices instead of whole cuts. Can anybody please help me with this problem?

This is what I tried to do with it:

-delete redundant edges after extrusion

-delete doubles

-rebuild whole thing like a ten times

Barn.blend (482 KB)

You have random vertices in the middle of the edges, so the face become an ngon, so blender doesn’t really now how to treat it when subdividing, so in the longer edges of the 4 sides go in Vertex selection mode and Dissolve the vertices ( Select vertice => “X” => Dissolve vertice ) It should work fine.

Thank you for response. One more little question why did vertices dissolve on first try? I was deleting them three or four times each, is it a glitch in my version of Blender?

Im currently running Blender 2.69.0 under Linux Mint 17 Qiana.

It’s because there aren’t only n-gons, but also unconnected edges and there are two vertices that aren’t connected to anything. How you have managed to make those, no idea.

It’s not probable put possible. I don’t recommend using repository versions of Blender. It’s pretty much the only software you’re better off downloading from the website on Linux. If there is a problem with the official, it should be reported in Blender bug tracker, if it’s a problem with the repository version, it should be reported in your distribution support. The official from the website validates the problem in Blender since there is no official repository for it.

Repository versions have many problems and it’s always better to at least try the official before asking questions, otherwise you’re wasting everyone’s time. It’s easy enough - Download, unpack, run.