Subdivision Surfaces

the textures look weird when I add a subdiv. I know there is a way to fix it just don’t know how.

how weird?

try to check the box “subdivide UVs” in the modifiers panel

If you are using UV textures when you uv unwrap your object select ‘Use Subsurf Data’ in the unwrap options. This is a new option in blender 2.62