Subsurf and Edge Split modifiers: need help

Hi all. Been a while since I’ve done any “blendering” or any posting on here. I’m back with the latest Blender release (2.48).

My problem is with Subsurf and the new (to me) Edge Split Modifier. I am trying to make this model of a Battlestar Galactica Colonial Viper MkII accurate with the smooth sides and sharp edges.

In the first attached image is the current rendered model:


Here you can see my model and the modifiers in the window (notice the stacked order and my settings; are any of these my problems?):


Finally, this image illustrates what I am trying to accomplish. The RED lines are surfaces that should be smooth. The BLUE lines are edges that are already Marked Sharp (selected edges, then Ctrl+E, then Mark Sharp). Not all the marked edges are shown, but this should illustrate my point. Some are out of view / obstructed in these images:


Would someone please help me to understand what I am doing wrong or not doing at all? I tried the SubSurf on “Catmul-Clark” but that just makes it rounded and distorted everywhere. I can post an image of that if you would like?

Thanks in advance for any help.

~Angel

First thing is you have to set your meshobject smooth in the Links and Material Panel.
Otherwise you won’t see any smooth edges.(But perhaps you have done this anyway)
Next thing is your subsurf modifier should be on top of the edgesplit and set to CatmullClark.
If subsurf is after edgesplit it will tear your mesh apart because of the splitted edges.
If you select all edges you want to have hard and Mark them Sharp you can deactivate the FromEdgeAngle option in the modifier.