Subsurf Modelling problem

Ok, ill try this again. I will reword my question. Or maybe im such a lunkhead
no one will answer. The problem I am having is I used the “to sphere” option under Mesh tools “F9” on a cube Mesh object. Now anytime I use the subsurf button on a mesh cube it turns my cube mesh into a sphere and “not a cube mesh with rounded corners and edges” like it normally would. Everytime I use subsurf button on a cube mesh my cube mesh comes out as if I used the “to sphere” option also. Any ideas?
I also uninstalled and reinstalled blended and nothing. I still have the same problem. IS THIS A BUG?

Saw that question but I couldn’t answer as the site was suffering indigestion.

That is regular subsurf (subsurface) behaviour. The cube becomes the “cage” and the new subsurfaces “hang” inside it. To understand it better hit W-1 (W and choose Subdivide) in edit mode and see how the profile of the subsurface changes. Subdivide again and again and each time the subsurface looks more and more like a cube.

Of course, if you leave the cube at “To Sphere” then the mesh (not the object) will be a sphere and so will the subsurface, no matter how many times you subdivide.


Have you tried subdividing your cube before turning on subsurf? Try this: Add a cube. Turn on subsurf. Go into edit mode and select all your verts. Subdivide your cube a few times. You should now have a slightly rounded cube. If this doesn’t work I’m sure there are people that are more knowledgeable than I am who can help you out. Oh, BTW, Welcome to elysiun!

edit Looks like Fligh % beat me to it. Oh well. :smiley:

Thanks for the help guys. I subdivided the cube after hitting the subsurf button. Sure enough I got my cube with rounded edges. Subdivided twice.

Now I was just curious that before I had ever used the “to sphere” option I didnt have to subdivide my cube mesh to get a cube with rounded corners. Only after hitting “to sphere” do I have to subdivide. Also, the vertices were concentrated in the corner of the messh rather than proportionally arranged around the mesh. It seems as if the “to sphere” option is stil on by default or something. How do i turn it off?

also handy for rounding the edges of a cube is the bevel feature, accessed with the W key. you can turn up the levels for more roundness.

I am a lunkhead. Thanks for the help guys. Waaaa! Waaaa!
A blendering I will go!

You can obtain beveled corners without subdividing using a technique present in 2.35 and up called Hard Edges. Basically you select the vertices that make up and edge that you want to change its hardness and press Shift-E. You then move your mouse to change the hardness value.

For a cube it’s very simple- you’d select all the verts and press Shift-E. You probably want a value of about 0.6. If the edges “stick” to the verts, you need to turn up the subdivision levels. 0.6 works well with 3, but if you try and go above 0.6 they will stick. With a subsurf level of 4 you can go up to about 0.73.