Subsurf Modifier not working

So, my Subsurf isn’t working and I don’t know why. TO be more specific, it’s not working on a specific object I made. It works for every other item I’ve used it on in the same scene. It also worked on this same object before but suddenly stopped working at all and on top of that, it’s also doing weird things to my materials. I have other modifiers on this object but they don’t seem to be the issue seeing as how when I turn them off and even outright delete them I’m stuck with the same situation of the subsurface not working.

Hath thou any wisdom to impart?

hard to tell, you could have disabled its visibility, or it is not at its right place on the modifiers stacks, maybe show some screenshots or share your file?

I meant to upload this with the original post but forgot. But there, as you can see, the modifier is visible, no matter where I move it in the stack it’s the same result, tried applying scale, deleting it and re-adding it, deleting the other modifiers to see if they’re causing it and now I’m at my wit’s end. I have no clue what’s to do.

That happened to me the first time I tried making serious use of a Blender 2.8 build. That’s when I discovered that the old subdiv code had gone, you now had to build with OpenSubdiv.

Try “apply”ing the modifier; do you get an error report in the terminal window? That’s what I got.

Could you share the .blend file?

furniture set 2.blend (918.7 KB)

Also you may notice that it’s doing weird things to my materials.

You have the modifier disabled in the viewport. Soon as I turned it on, it became more curvy.

Hang on, let me amend that. You have a bevel followed by a subsurf. If I disable the bevel, the subsurf looks better.

I think this is normal behaviour, given what bevelling does to the mesh.

Visibility was turned off because that’s how I last saved it. If you look at the image I posted earlier, you’ll see it’s on, but no effect of the subsurf. Also, I think I dragged a vertex too close to another but I went over this thing with a fine tooth comb and I can’t see which one it is because none is causing a reaction. :disappointed_relieved:

Your have Display Modifier in Edit mode turned off. Also in Edit mode, with that visibility turned off, your subsurf won’t work. It will only work in Object Mode. Either exist edit mode or turn it back on.

The bevel is doing things to the mesh before the subsurf, and the net result is what you see. Turn off the bevel, turn on the subsurf, and you probably get something closer to what you were expecting.

In terms of “weird things” to your materials, you mean the curved boundaries between them? That’s an inevitable result of the way subsurf works. You can control it by applying a crease on the boundary edges.

I can fix up the boundary between the wood and the cushion around the top of the front leg by setting a crease of 1 on the four edges around the top of the leg.

Not so easy to fix the back leg, because the topology there is a bit messed up.

I can deal with the tedium of fixing the geometry but my main issue now is why is the subsurface modifier working for you and not for me?

I turned off the bevel.

Yeah, I turned off the bevel on my end as well, leaving the subsurf as the only active modifier and it’s not taking effect at all.

So just to be sure that this is not a bug with Blender that you use in your OS, is Subdivision surface modifier working for you with this file?
furniture set 2_mod.blend (688.8 KB)

yeah it works in that file you sent. So, what’s wrong with my file then?

I didn’t open your files, jugging by discussion here i will say you may be tired, step away from Blender for awhile( hours), do something else fun. Come back fresh at it, compare the 2 .blend files you will see more clear.

About the file that you shared, I guess what happens has already been explained about Bevel modifier.

About this other:

I guess you have forgotten to enable the visibility of subsurf modifier.

If you look at the image I posted in the beginning, isn’t the visibility on? I even circled it.