Subsurf modifier - strange result

Hi everyone,

I have got a problem with a model that gets messed up when I add a subdivision surface modifier to it. Until now I have just redone the modelling to avoid this kind problem when it has occured, but this time I figured it was time to ask here and learn how to fix it properly instead.

In this case I have a very basic shape which I have extruded and subdivided, but the result isn’t smooth at all:


What is the problem here? How can I fix it without having to redo everything? I tried recalculating normals but that didn’t help.

.blend file: http://www.pasteall.org/blend/18491

Add additional edge loops to strengthen to edges or add a crease to the edges (Shift+E). See attached blend file

Attachments

KANNA_FAIL.blend (490 KB)

Whenever you have polygons with more than 4 vertices, subdividing will produce strange artifacts. Make sure you have only 3- and 4-point polys in your mesh.

Easiest way to get the supporting edge loop around an n-gon is to inset it (i key).
Then, if you want to split it to quads, select the vertices you want to connect and join them (J key) instead of filling them (F) or use the knife tool (K) to cut edges between them.

[ATTACH=CONFIG]209551[/ATTACH]

Richard,Safetyman,JA12: thanks! Adding supporting edges using the inset-key worked fine, crease too, but in the end I decided to remodel it. I have now learnt that I should take it easy with b-mesh and try to plan the modelling and keep vertices to a minimum in each face. This particular shape was easy to model using simple extruded boxes and it turned out great.

Btw, after finishing this piece I could also finish my very first 3d model (yay!)