Subsurface scattering in Eevee Material preview mode

Hi everyone,
I use Blender 2.82a and I have an object with many materials that use Subsurface, but in the material preview mode, it slows down my machine a lot, and make me can’t work in this mode, I just want to find a way to disable Subsurface scattering but I can’t find it, and I don’t want to turn it to zero on each materials. Is there a way to do that ?
Thanks !

There is no way to disable SSS globally.

The only thing that could help would be to set amount of Samples in Subsurface Scattering panel to 1.
Otherwise, you have to disable materials, one by one.

Oh ok, I tried already to turn it to 1 but it’s still too slow…

There is one manual trick you can use, but involves some work.
Make a node group where you parse in the sss shader, albedo and normal. Inside you have a 0/1 switch that is not exposed, that chooses (mix shader) between the original SSS shader and a simple Diffuse shader with the albedo and normal hooked up. Now drop this node group between any SSS shader and the next one. I tend to place such overrides in the World shader - just disconnected node groups where I can adjust global settings (SSS shader overrides, light group controls etc). Since the switch is not exposed, it will be global for anything using the node group.

But yeah, maybe SSS->Diffuse evaluation should be a simplify option?

Sounds like a good idea, I’ll try that, thanks a lot for your time !