Subsurfed cloth bakes OK but renders static at initial position (NOW SOLVED)

I’m having some problem with subsurfed cloth (subsurf modifier before the cloth modifier). I bake the cloth, and I see it moving OK. Then, if I press ALT+A, I see the animation OK, but if I render the animation, the cloth remains static in its initial position in all the frames.
If I remove the subsurf modifier (and rebake) it renders OK.
I’ve reproduced the problem with the simplest blend: from a new file (only the cube), I add a plane around two units over the cube. The plane has a cloth modifier with the default cotton values. The cube has a collision modifier. I bake and render the cube, it renders OK. I add the subsurf and move it before the cloth modifier. Rebake and it renders static.
Can you give me any idea about the problem?
A workaround can be to apply the subsurf modifier, but I think it shouldn’t be necessary. Another workaround would be changing the order of the modifiers, but the result is not the same.
Thanks in advance for your help.
(I’m using latest 2.47 official release for windows modified on 19 september)

                • EDIT: FOUND THE SOLUTION - - - - - - -
                  You need to put the same level of subsutfing for edition and for render. It seems that baking is done with edit level of subsurf, which is fine for editing, but doesn’t work with rendering if the subsurf level is different.
                  This means double baking or working with the same level in both cases.
                                • END OF EDIT - - - - - - - - - - -

http://www.pairal.net/subsurfedcloth.jpg

Hi, Pairal, thank you so much for posting this!! I have the exact same problem, but it appears you have solved it for me! I didn’t realize the subsurf modifier was causing the problem.

By reordering the modifiers so the subsurf is second also fixes the problem, but you’re right, it probably shouldn’t be necessary. But it works… so… I’m happy!! :yes:

P.S. I was having difficulty getting a response to this… so I am most grateful for your post!

You say that “By reordering the modifiers so the subsurf is first also fixes the problem”. Not in my case. On the contrary, I ONLY have the problem when subsurf modifier is before the cloth modifier (up: subsurf; down: cloth).
When cloth modifier comes first, everything is OK.
I don’t like the idea of applying the subsurf, so I’m still trying to find a solution, but maybe this is some sort of bug.

Pardon me… whoops… :o You’re right… I should have wrote “by reordering the modifiers so the subsurf is second fixes the problem”.

My apologies.

Changing the order of the modifiers produces a diffferent effect, because then the cloth modifier works on the low resolution (unsubsurfed) mesh, and the quality is lower.
You can watch both results in the 3d window, and yo’ll see the difference.

I’ve found the solution and edited first post

Thanks, I confirm both the problem and the workaround!
Did you report to the bug tracker or check if it already had been?