Suddenly textures don't work in 2.79

Hi all,

Still pretty new & been jumping between 2.79 and 2.8 to learn how to do “the same things”…

Anyway, up until about 20 minutes ago, in 2.79, I could start a new file, add a plane, create a new texture, go into cycles, add a node with an image, and see the image in the preview as well as renders.

Suddenly, it’s not working.

Just to confirm, I tried exactly the same sequence in 2.8, and it’s working fine.

Any ideas?


Did you…

Go into edit mode
Select all
Press U > Rest
(basically create a UV map - which controls which bits of the image go on which bits of the mesh)

Hi - thanks for the quick response!

What’s “rest” ?

I didn’t, but I didn’t do it before, either, and it worked…

I didn’t do this in 2.8, and as noted, that’s working fine!



Press U > RESET

There are options for having a plane come into existence with a UV map already on it… see the panel bottom left of the 3D view.

1 Like

Reset worked! Thanks!

Not sure what happened, but thanks. I should learn UVs… been doing 3d as needed for a long time, and never learned it.