Sun interferes with sky color

I’m trying to render a sunset on an alien planet. I’ve got the sky colors set up, but when I check the “sun” box on my sunlamp, it overrides my sky and changes it to a blue and yellow sky.

The first render I enclosed shows the sky without the sun box checked, and the second with.

How do I get it to stop changing the color?


Assuming you’re using a Blend Sky, you can probably get a better result by modifying the Sun/Sky blending mode and other values. The attached .blend shows a few setting for a much different effect than the default, and one that matches the file’s Blend Sky more closely. Play with it.

MartianSun.blend (388 KB)

Thank you. Previously I had experimented with the different settings, but neglected the World panel.