Super Blocky Materials

Lately I’ve been noticing how sometimes when I add a very simple color material to an object that the object begins to render in a very super blocky looking way. However, while its still in the viewport it seems as smooth as it did before adding the material.

Here you can see in the first picture that her hair looks smoother than in the second. What can I do to make it not do that? I’ve tried subdivision and smoothing already and neither has the desired effect. I tried the spec and reflection and adjusting the lights too. Maybe I’m doing something else wrong though.

Help wanted. Thank you.

http://img359.imageshack.us/img359/5549/marwapt5.png

http://img377.imageshack.us/img377/1451/marwaother2pi9.png

If you set a mesh or faces smooth and then turn on auto smooth causes any angles that are less than your threshold limit will recieve smooth lighting. There’s probably something else going on there. The two pictures have obviously different light setups which looks layer based, but the most likely answer is the material shaders that you’re using. I’m not verry good with them but I believe that Wardso shading rms option has something to do with light reflection angle as well as the Refr option located in the Blinn shader, sort of like the Index of refraction setting for ray transparency.

Done and done. Thanks - problem is resolved.

Oh wait a minute, its still doing the problem.

Can you post a blend file? It has to do with the Autosmooth/Set Smooth settings.
[EDIT]Sorry, probably not Autosmooth as you’ve tried it. But post that file anyway. I can play with the materials to see whats going on here.