Super Duper save/load scripteroo!


(saluk) #1

Well, it is still a LOT of work to get from just having this script to actually having a game that you can save in. But, never fear, a tutorial comes with em! In less than an hour, if you know what you are doing, you should be able to get things working. Some updates I have for the future will be support for multiple save files, and support for more than one level. Right now, it’s still the best save system around for blender games.

If you have any problems with it, and want to yell and scream at me, feel free to do it here, I haven’t thourouly tested it (made a few changes from pooland scripts to make it more general) but I didnt change too much. Chances are I made a really stupid mistake somewhere. If you really cant get the hang of my tutorial, you can send my your blends, and I could try and get saving working in them.

Good luck fellow blenderers!

http://www.angelfire.com/ego/spinhead/saveload.zip

edit: bad link!


(gargola) #2

downloading right now!i’ll see if i can do it alone,if not wait for my mail!.. he he! :slight_smile: thanx for been so kind! :slight_smile:


(gargola) #3

ok.i got it.gone to work! see ya! :slight_smile:


(gargola) #4

i tried to email youbut the email on your page doesn’t seem to work.anyway,i got problems with the script.in the first part i ran the game, pressed the key to save the game and an error in the dos windows appeared.don’t know how to fix it.tell me how i can email you or i can post the file on my page.please help me. :slight_smile:


(saluk) #5

email is [email protected]

that’s what’s on the site and it really should work. If not, you can private message me here, or we can just discuss it in the forum (I’d prefer this one). What I need to know is what the error was in the dos window. Thanks for helping me get the kinks out of this, I want to make it easier for people to use. If any of the steps in the tutorial were confusing, let me know.


(gargola) #6

ok.the error says: Python script error:Traceback (most recent call last): file “save.py”,line 25,in ?
AttributeError: Unable to find requested sensor

i don’t know what the heck that means! he he!please help! :slight_smile:


(saluk) #7

Ok, thats a pretty easy problem to fix. It means that the script is looking for a sensor that it cant find. If you didn’t name the sensor the name I told you, or forgot to connect one of the sensors the script needs, than it’s not going to work. Make sure you followed my instructions right, and if it still isn’t working, than I forgot to write something in my readme:)


(gargola) #8

ok,i think i worked out that part…i’ll continue right now.if i get in troubles again,i’ll tell you. :slight_smile:


(gargola) #9

Saluk,please check your mail. :slight_smile: