super noob here, lmb does nothing in 3d view, why?

As the title says, I’m a super noob to Blender (and 3d game modeling in general) and I was working on my project last night, saved it, everything was great but today I opened it up and in 3d view the LMB does absolutely nothing. Normally when I click the lmb the reticle moves to where I click so that any new mesh I add will appear there but now nothing happens when I click the lmb. When I cold start blender (with no project) the lmb works as expected. I must have clicked something on my project and I can’t figure out how to fix it. Can anyone help? Thanks a bunch.
-bosforus

Update: Problem “Solved”
I’m still not sure how the problem occurred but I seem to have fixed it. I realized that with an object selected I can go into Local View and the LMB behaves as expected so I did “Select/Deselect All” and then went into Local View then deselected everything. Problem solved.
If you took a look at my problem and were stumped, I hope this is the permanent solution.
Thx