Suppressing Reflections of a Single Part


I hope this isn’t a ridiculous question to ask. I’m still new to Blender and didn’t know exactly what to search for, so my previous searches have only confused me more.

I have modeled a laser moving through glass optics on a glass base:

I don’t want to see any reflections of the laser on the glass base or on the optics, and I don’t want to see any shadows from the laser. I basically don’t want to see any effects of the laser other than the laser beam itself.

I’m assuming that I need to put the glass base and optics on one layer, and the laser on another. This is where I get stuck. How do I superimpose the two layers together, through composting? Can someone point me in the right direction on how to proceed? Any help you be much appreciated! Thanks!

Actually, the only thing you need to do is disable the option Traceable in the beam’s material. Shadow options (recieve/cast) are located in the same menu.


Thanks for the response. Disabling the traceable option in the beam’s material, and adjusting the shadow options, almost gives me the effect I want:

I don’t see the beam’s reflection or shadows on the glass base anymore (a very big improvement), but disabling the traceable option causes any part of the laser beam that lies behind an optic to be hidden. Is there a way to still be able to see the laser through the optics without seeing its reflection?

When disabling Traceable, you actually remove the material and the object(s) associated to it from any ray trace calculations, such as reflection and refraction. As far as I know, there isn’t a simple solution to just exclude one but include the other. It’s possible though that it can be done with the help of scene/render layers and passes.

I don’t have a clear solution right now, but I’ll give it a spin later when I have time. Unless someone else helps you out. :slight_smile:

So I figured it out, and the solution turned out to be pretty simple. If I turned off the traceable option in the laser’s material option, any beam behind the optic was hidden. There is a material setting to Invert Z Depth which had the effect of only showing the laser beam that was in front of the optics. I wanted the laser beam to be shown both in front of, and behind, the optics. I simply duplicated the laser beam with one beam having the Invert Z Depth option selected. One beam was shown in front of the optics while the other was shown behind the optics, giving the illusion of a continuous beam!