Surface Book Pen Problems using Grease Pencil

I bought a Surface Book to use with Blender Grease Pencil but I have problems with the starting point of the drawings when using the Pen. This problem has been described by Daniel Lara of Pepeland as seen here in this video link https://t.co/Od5T5csS1B?amp=1 . Has anyone here been able to resolve this Issue? Is it a bug that is being worked on by the developers yet?

I cannot draw successful drawings because of the delay in the starting point of the drawing. For Example, I cannot draw a horizontal line and then draw vertically lines connecting to the Horizontal line. The first part of the lines do not start where pen makes contact with screen. Watch the video in the link.

1 Like

Currently, bugtracker is only open to report crashes or restricted to developers or team members of openmovie Spring.
When it would be open to report bugs, you can be sure that will be reported and treated seriously as any bug reported and confirmed.

Daniel Lara is member of Grease Pencil team. He talks to grease pencil developers regularly.
You can be sure that if he takes time to describe problem in a video. Developers are aware of the problem.

Grease Pencil branch was merged into 2.8 branch some weeks ago. Status of 2.8 is alpha.
Developers may currently have other priorities than compatibility with all hardware.
Problem could take months before being solved. A stable 2.8 release is not expected before next year.
So, users have to be patient.

I know how to fix this: it’s caused by the Surface Pen scrolling instead of drawing on the latest Win update. To fix it, you need to add an entry to the registry as described here:

Or, in short, open a command line with Admin rights and run:

reg add HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Pen /v LegacyPenInteractionModel /t REG_DWORD /d 1 /f

2 Likes

Sorry, forgot to mention: to apply the change, just re-start Blender. Also, be aware that if you apply this change, it will disable pen scrolling on other applications; but at least you’ll be able to use the Grease Pencil.

I put in the command on the command line and hit enter. It gave a message saying Completed Successfully but this did not solve the problem. I can draw and connect lines in any other program as before but not in Blender. It still skips the starting point of drawing.

Hi this problem is not related to this type of pen. I have same issue with cube mix plus that has build in wacom tech. Thats more of a win10 thing where they messed stylus with finger input. I will look on this thread how to resolve this.

@edit, ive found my old bugreport. Still same problem.
https://developer.blender.org/T53601

1 Like

I just realized that this is the same suggestion made by Rezzer a few months ago. I’ll try to read the thread more closely next time!

Hi all, I was going through the MS forum thread Pen issues after the Fall Creator update and found a registry tweak that seems to help on my HP Spectre x360 15-ch0xx (with a HP Tilt Pen). The helpful post was made on April 25, 2018 by EliseFrappier, but I can’t figure out a way to link directly to the reply.

Anyway, she appears to have resolved the lag issue with the following steps. However, it appears that applying this fix will disable the “shortcut” button functionality of the eraser button. Also, I have not tested the impact this has on other applications like Krita or the Adobe suite yet.

  1. Open a Command Prompt window as an Administrator
  2. Run reg add HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Pen /v LegacyPenInteractionModel /t REG_DWORD /d 1 /f
  3. Voila! The drawing lag should immediately be gone (I restarted Blender, but did not need to restart my machine).

Try out the latest Blender 2.8 beta. It has recently been updated to support the Native Pressure API alongside Wintab and has fixes for the laggy pen problem.

1 Like

I work on a Lenovo Yoga 720 15". The problem seems to still be there as of today’s build, but seems to happen only about maybe half the time? Somewhat confusing.

I had done the regedit recommended in one of the previous posts prior to trying the most recent builds. I reverted to the previous state (no legacy pen interaction model), and as of the Jan 18 build, my problems appears to be solved.

Thank you everyone for your input!

1 Like

Hi chris, its something different. Ive installed newest wacom feel driver 7.3.4-47 on win8.1 surface pro (1gen) and there is same lag problem. So it is not win10, windows ink or wintab issue. Right now i use surface pro win8.1 with very old wacom drivers and it works fine but when i try to switch system to win10 the only available driver is 7.3.4-47 ;/

Hi Guys!
Just made an account to tell you:
Today there was a new Blender 2.8 release. (Mine was from last year I think)
There is a new Option for Tablets.

Edit --> Preferences --> Input --> Tablet
I changed the setting from Automatic to Windows Ink and it worked like a charm.
Wintab had the same Problem.

Hope this helps and wasn’t tooo late!

Regards,

Michael