Surfaces are greyish and dull

Hi,
I’m an architect planning using Blender to render models built in ArchiCAD, my CAD-program. My plan is to build the geometry and the materials of my houses in ArchiCAD, and then put them into preset scenes of light and background (what the ArchiCAD SE doesn’t manage well) and render them.

My problem is that regardless what I try, the Blender renderings become quite foggy and Grey. The first pic is an ArchiCAD internal rendering, watch the vivid colors of the grass, for example. On the Blender rendering, this material is dull, and if I add more light, it becomes overexposed-whitish.

In this scene I used a bit yellowish white spot light with constant falloff and a bluish ambient light. The materials are unchanged except for the ambient amount is decreased from 0.5 to 0.2 to avoid burning in of ambient light.

What is Your opinion, what can I try or check to bring in bright and vivid colors?

Any tips welcomed, thanks in advance.

Attachments



There are lots of variables. Grass material setting, what did you set?

Try using Version 2.5 with linear workflow enabled. To me, it seems to make a huge difference in render quality for exterior architectural scenes.

I have made some process, with a bit better results, decreasing Texture’s brightness to 0.6.

I added a .blend, too, although i had to remove some textures due to filesize constraints.

2.5: I have problems with 2.5 under Windows, and haven’t tried it under Debian (I don’t want to use different versions, but I’ll give it a try again.)

Thanks

Attachments


3.blend (628 KB)

And a full render with current grass.

Attachments


What version of blender are you using? I may be missing something but when I import your scene into 2.49b or 2.50 there is some strange behavior with the shaders. I can use your texture in a fresh scene and duplicate the texture colors in the render but for some reason I am not able to do this by manipulating the material controls when using your scene. Even new materials in your scene are too dark so I suspect there is some corruption in the .blend.

I’ve been raising the emmisive to some value above zero to lighten - like with the grass. A dark filter, the emmisive adjusted to compensate, might be the simplest trick; sorry, don’t know much about Blender filters…Anyone know about light filters?

Thakns for the answers,
I use multiple versions, 2.49b, 2.50a2 on Windows, and an older, 2.46 or so under Debian Linux. (so Blender file corruption cannot be ruled out). Under Debian i cannot set up the python environment (a known problem), the prorgam doesn’t find the python libraries.

It is notable that the original geometry is done by ArchiCAD, and imported via Lightscape .obj, so some strange behaviour is not surprising. 3ds was also tried, but the geometry was corrupt every object was in the origo of the scene.

I don’t know where to set dark filter, is it a material setting?

Otherwise if possible, I prefer a global trick (ligting/atmosphere/render) to avoid dealing with materials after every sinele importing.

Thanks

I had problems with Ani8or after importing. This works for me with 3ds; I deselect the imported model, (A key), then I reselect the whole imported object, with one click, and then I open my texture buttons and find my textures in Links and Pipelines–that’s when I adjust most of my color settings. After that I press ctrl j key for join–a menu will come up, click Join…do all of this without moving from object mode. U can also get rid of the doubles by switching to edit mode and pressing the w key (all vertexes should be selected(pick Remove Doubles)).
I have to do it that way or when I try to move the model it will literaly fall apart; I don’t believe the textures are properly mapped, and probably won’t be, until I open them and then join the whole object, even if it didn’t start out as more than one object - a cube will come in with six pieces depending on what it was uv mapped with, and how many different textures there are - wild, huh!?!?

jeboddie1:
I’ve read about linear workflow, and i think it would colours less vivid.

Fun101:
How can I raise emissive?

Here are some current grasses. It is getting better, but, for example, the colour of the ground level terrace (not grass:) is tragical, compared to the original.

Attachments





See if this works for you:

Select the object.
Go to the texture panel for the material (F6)
In the Colors tab, increase the brightness control from 0.6 to 1.0.

Hi,
I’m closing the desired results.

I think the mistake that I had made was that for matte surfaces I set the specular color to black, now it is a yellow (RGB .352-.452-.101). The other important change was to set the shaders, Oren-Nayer and Blinn were set.

I think I’m far from a good result, but this is satisfactory now, except for the greenish (metal) roof.

jrboddie1:
I tried the brightness/contrast for the textures, now I set brightness to 0.8.

Although the texture of the grass is quite blurred, the original ArchiCAD rendering was sharp with whitish highlights, maybe it need some remapping, so it’s not perfect.

…And shadows are gone :frowning:

Attachments


But without oversampling, the grass is perfect (but the others not).

Is it possible to somehow switch off antialising for textures?

Attachments


There are several way to intensify the color. In shading (F5), on Shaders tab, choose Minnaert and Blinn. Play with the slider setting there. In Texture (F6), on Colors tab you can adjust Brightness and Contrust. Play with those.

Attachments


In 2.5 do you have colour management set? Otherwise, and in the older versions of Blender, you may have to gamma (de)correct your image before applying it. Otherwise you are gamma correcting your image twice. This will affect the ‘dullness’ of the image

Matt

travellingmatt
Wow, You said something important, since manipulating the image this way doesn’t need to set each material one after another, so suitable for my desired working method (building geometry and materials in Archicad and later lights/scene/render, and now post-process in Blender).

And does anybody have idea about de-subsampling of only the grass material?

Thanks

Posted twice

And two other questions:

  1. Is it possible to set properties of multiple materialis at once? I think is will have to set at least the specular/ambient alorighms (Oren-Nayer and Blinn) and some variables
  2. Is it possible to preset a material in a .blend scene, and then import my model in ArchiCAD, and not to overwrite the original, .blend material with the imprted one (supposing they share the same name)? That is, to fine-preset a material in Blender, and replace the not so good AchiCAD material with it?

Thanks.

  1. you can apply an existing material, then make a single user copy (click where it says “2” next the the name), and then make more modifications without affecting the original material.
  2. not sure, never tried that…

You might try adjusting the Image Sampling settings (MipMap, Interpolation, Filter).