Sverchok install error (I do have numpy installed)

Hey guys… Hope this is the right section for this…

So I just heard about the Sverchok addon for parametric design, and I was so blown away that I wanted to try it out… But it doesn’t launch once installed…

After having investigated a little bit, I found that the install generally goes south because the user doesn’t have a version of numPy on their computer, but I do!

So I really don’t know what is going on, or how to solve this… Because I know nothing about Python, except that my machine has it… :expressionless:

I’m using 2.79b, on a 16.04 Ubuntu machine…

Any ideas please?

PS: Here’s the error message in Blender as an attachment…

please, check this solution:


The simple reason for this - wrong numpy installation. if numpy inside blender, than it is all right.
try different blenders

Hey! You’re on the Sverchok team, aren’t you?

First, thank you for this amazing tool… Even though I still don’t know how to use it, I feel there is tremendous potential in Sverchok, for Blender but also for algebra in general… So thanks again! You’re a superstar in my book!

As for your solution, I can’t explore it right now, but I’ll do it later in the evening and I’ll come back here to tell you if it worked! :wink:

Hey… So I did give it a try, but things got so messed up that I have no copy of Blender on my computer now… The link you provided is for versions you have to “build” yourself, and I don’t know how to do that… That’s why I use MATE, ni terminal skills at all!

It’s all right, I’ll try to find a workaround, I always do eventually… :wink:

try official blender site download or graphicall
Use downloaded zip archive of blender and run executable binary file inside

Hey nikitron… I did try the official site, the zip and executable thing, and even tried 2.8, but still doesn’t work…

Now, I realize that my difficulties come from me not knowing how to use the terminal…

Still have to try Graphicall… I went to their site for the first time, and found dozens of different builds… Do you recommend one in particular, that would be likely to work?

YESSSSS! It finally works!

In fact, I just tried the other version (2.79) of the very first link you sent me, and this one works!

Thanks again nikitron! For the addon and for the help! :clap::clap::clap: