SVG convert to Mesh -- Creating Extra Polygons?

I am familiar with Adobe Illustrator so I built my initial shape that I want to extrude from, and saved as an SVG.
Got this inside blender and converted to Mesh, as seen in this tutorial.


As you can see my shape had a lot of polygons added.

/uploads/default/original/4X/3/c/6/3c6c8891311451dd0fdd49423e32a0d03c24c5de.pngstc=1
The shape made in the tutorial I watched did not have a lot of polygons added (example above) and I am not sure why this happened to mine?

Attachments



You can merge adjacent selected faces with F though if you want to extrude them it makes no difference if you have one or 20 faces

I think that merging the faces would work. However when I use my Box Selection (B) and drag over all the faces, When I zoom in I can see that many faces are not actually selected.
For this situation I realized I can join them all into one object, then select all… but I still would like to know why the Box Selection isn’t selecting all of the faces even though I make sure to drag around the entire object.

Attachments


You’ve made a lot of extra moves which now strike back. Make a whole design in Blender.

  1. Add Bezier curve and subdivide once in edit mode. Scale all points Y 0.
  2. Make your U shaped design: Top Ortho view, grab end points, move Y and rotate as needed.
  3. Set curve Fill to Front, Bevel Depth as needed (around .15 looks good)
  4. select all points and flatten curve by setting Tilt (Ctrl-T) 45deg.
  5. In Object mode, convert Curve to mesh - Alt-C
  6. In edit mode check for overlapping verts near the middle, scale X overlapping pair of verts if needed.
  7. select all, move Y away from the object’s origin.
  8. top Ortho view, press Spin on T-pane, checkmark Dupli. Adjust amount of duplicated elements on T-pane options. Delete doubles, there will be some if you went 360deg.
  9. to be sure there are no misalignments, select all and scale Z 0

Before Spin, delete one or two loops from the ends of the U shape and add Subsurf modifier if you want ends to be rounded.
Add Solidify modifier or extrude mesh Z.

http://www.pasteall.org/pic/show.php?id=101709

Edit: to the imported svg - try Delete, Limited Dissolve on all selected verts in edit mode. Chances are, Blender will deal correctly recalculating mesh to n-gons. If there are weird overlapping faces you’d need to do this on each ‘petal’ individually (which doesn’t look like a fun).

eppo, the Limited Dissolve worked perfect on another (more recent) project I was working on. That solution worked perfect.
Also, how do I mark this thread as “Solved”?

Actually, I spoke too soon.
It worked fine in Blender, and I even exported an FBX and brought it back into a new Blender project just to confirm that it still had the clean polygons (and that worked fine also).
However, as soon as I brought it into Unity 3d (game engine), all those original polygons showed back up again. Is there any reason that the old polygons would show up in an exported FBX? Is there a step I’m missing or something?


This is normal. Most game engines (including Unity) don’t support anything else than triangle meshes. In order to draw meshes on the screen (using graphics hardware), but also for many other algorithms, the mesh needs to be triangulated. Unity doesn’t hide this fact from you, whereas modeling tools will maintain triangulation internally, so that you can work at a higher level.

okay that makes sense. But it’s funny that that simple wooden cutout character ended up using way more polygons than any other model in my game