SVN GLSL no good with ramp shaders here

I am wondering if this is an ATI on Linux bug or if this is common to all of you too.
Here’s the .blend already set :
Here’s an image of what I get and the settings :
Suzy should be all blue and black:
Thanks for helping. :slight_smile:

Hello, I get a different (correct) result with your .blend. It appears to be a bug in your ATI.

Thank you for your help. :slight_smile: