Switch between video files

One of my goals is to make my All Free VFX tutorials look nicer using blender, which will include multiple camera angles. However one of the things I ran into is camera switching. If I end up with say three video files, how might one go about switching between them in blender? I would like to be able to easily go from angle one, to angle two, and back with cross dissolves or some other transition (the same each time). In Final Cut Pro for anyone that knows. you just press a key and it marks the track ascociated with that key as the active one until you select another. Any help here would be great, as this would make my life a bunch simpler.

~thanks, istvan - creater of all free VFX

there is no ‘multi cam’ feature in Blender, the only way you can switch them is using the sequencer editor, and just trim the clips or use fades like you would in FCP

ok, well i’ll put in a feature request, but in the mean time when you said or use fades, does this mean that I can switch between clips without deleting anything?

You can do it if you set the top strip to Alpha Over and use an Ipo to control it’s visibility. The only downside is that if you use more than one strip, the situation could get hairy if you’re not careful.

Ok, well I guess i’ll have to do more work than I was hoping for, or I could set up a cool node system, not sure how yet though. I might even re-design my whole plan, but I’m not to keen on doing that. Thanks for the help, Istvan.

I spent half hour today figuring out my first semi-large node project. My solution was to have three ‘zones’ in the time node, and each of them corresponds to a color ramp. One of the color ramps is white the first third and black the rest, the second is white in the middle and black the rest, and no points for guessing what the last color ramp is set to. Anyhow the first two are connected to a… well i’m stuck. I think I used to be able to add a mix node and then do an overlay to put one video on another, but I can’t seem to now. So here is my question: if I have a value, between 0 and 1, how can I choose a video depending on which it is. 0 is one video, 1 the other, and fade in between. I’ll attach the blend if it helps.

~thanks, Istvan.

Attachments

video_selector.blend (306 KB)

Hrm… I’ve not looked at your .blend file, but the fact that you’re trying to use the node editor for this leads me to think that you’re going about this the wrong way. It’s much simpler to use Ipos in the VSE. Sure, syncing may get a bit hairy if you have more than two clips to switch between, but it’s actually not too horrible to manage.

Trying to use the node editor just seems like you’re overcomplicating things.

Actually what I have is quite simple. It is only one time node, and if the value is in the lower third of the time node it is one clip, the middle third a second clip, and the upper third of the time node it is the third clip. so there is only one curve that chooses between all three clips. This is good because here is my setup for the final render: on the lower third there are three boxes, each with one camera angle. On the upper two thirds there is one large box with the main camera angle. This main angle switches between the three clips to which ever is most appropriate at the time. So if I am setting the render up, I can watch image editor to see what all three of the video clips are by watching the three boxes in the lower third, and to switch angles for the main box I can add a new point in the time node. This should be fairly simple no? the only problem is that I’m not getting a good switch, the overlay… isn’t working. I’ll attach an image to show you… wait… I might have it! i’ll post what I find it a second, but while setting this up I had an idea.

I GOT IT! All it took was the mix node, which works fine since the values are 1 and 0. I uploaded the .blend for ya’ll to look at. Make a test render, and you will see that I can fade between the colors (will be video inputs). You will also see how simple it is to switch, just move the slider. Thank you all, and please, comments are good. Oh and also check out my thread about my series called All Free VFX

Attachments

video_selector2.blend (181 KB)

Sorry, I keep changing my mind. The mix node isn’t working when it is set to mix. I have attached a screen shot of my node setup, and an image of the output. The ‘mix’ worked with colors, but not with images it appears. well, back to the testing… Please, if you have a solution post it here to save me the time!

Attachments



Ok, this thread is me rambling, almost like that wretched twitter. anyway, I fixed the problem, I just needed to round the numbers. One problem down, i hope not many to go.

The next thing is that I can’t seem to make the translate ‘real’. in other words, when I translate one image, and I want to put another image on top of it, they don’t behave nicely. some of the translated/scaled image gets chopped off, and the other image doesn’t go on cleanly. any ideas?

After some poking around, here is what i’v found. It seems that the translate node will not move the alpha channel… soooo… workarounds anyone?

Translate the alpha as a separate image and then re-apply it after.

But I still say that the VSE is the better tool for what you’re trying to do.

and as if that weren’t enough I can’t seem to get rid of the alpha! If i split the RGBA and combine them all but the alpha, it still shows an alpha… what am i missing?

I’ll be more specific. If I take an image, no alpha plain old jpeg image, alpha over something else, and scale then translate it then split RGBA, make a noodle from A to composite, there is a white square that is the size/position of the scaled image before translation. However if I take the image with no alpha over first there is no problem. so A. why is there an alpha, and why can’t I seem to get rid of it, and B. why isn’t the alpha that isn’t supposed to exist not translating and C. (most importantly) what can I do about it?

To belabor the point here is another description: If I split the node that has the alpha over, scale, translate, into its RGBA and view the A it is a white box where the image was before translation. However if I apply an alpha over to that again, nothing appears outside where that white box is… why?

Using nodes, identify your switch points and thread to the fac on the mix node. Using the vse, cut the strips and mute out what you don’t want.
in nodes, the alpha output image is a black and white mask that is alpha 1 completely.

Here, with the wonderful grease pencil, let me show you. On the attached .blend I have indicated you should change the value with the arrow to -150 and -200 (sorry about the hand writing, my tablet is not hooked up now). Notice that the smaller box gets clipped at the bottom as it moves down. Why? I want it below that line, but can’t seem to get it there.

~thanks for any help, Istvan.

Attachments

alpha issues.blend (240 KB)

oh, and I would like to keep all my data, hence being resistant to the VSE, that and the project was going to need nodes anyway, and I also wanted to learn the nodes better, so it seemed perfect. anyhoo I got that bit working fine, it isn’t the switchin anymore, now my goal is to put in those three camera viewers. The ones that each show one angle constantly that are on the lower third or so.

~ thanks for all the help so far, and reading my ramble - Istvan