Tablet driver crapped out in Ubuntu

Getting help on this is probably a long shot but I’ll give it a try before reinstalling Linux (or, shudder of shudders, going back to Windows).

I’m using a usb-based tablet pc so it’s a little more complicated than a regular Wacom tablet but it’s not too bad. I got it working on the first try originally and it worked great, but something’s changed and I haven’t been able to reinstall the driver after several attempts.

Here are the instructions for patching the driver and installing the patched driver -

Link

There are two sets of instructions, the 2nd begins with CHIIIII (the author)

Here’s me following the instructions -

Link

(btw I’d already patched the file so that part doesn’t show up)

Here’s my xorg.conf - shouldn’t be anything wrong here but wth I’ll throw it in for completeness -

link

Thanks for any ideas.

I’ve had a lot of trouble getting my graphire 3 to work properly on 8.04 on my laptop. I solved it by moving the wacom part in the serverlayout section before the touchpad section. Maybe it’s the same for you.

change:

Section "ServerLayout"
	Identifier	"Default Layout"
	Screen		"Default Screen"
	InputDevice	"Synaptics Touchpad"
	InputDevice "stylus" "SendCoreEvents"
	InputDevice "cursor" "SendCoreEvents"
	InputDevice "eraser" "SendCoreEvents"
EndSection

into


Section "ServerLayout"
	Identifier	"Default Layout"
	Screen		"Default Screen"
	InputDevice "stylus" "SendCoreEvents"
	InputDevice "cursor" "SendCoreEvents"
	InputDevice "eraser" "SendCoreEvents"
InputDevice	"Synaptics Touchpad"

EndSection

and see if that helps.
And maybe instead of


Option "TopX" "100"
Option "TopY" "100"
Option "BottomX" "28400"
Option "BottomY" "17900"

you could use keepshape “1”

Thanks for the suggestion, but it’s still not working.

Anyone else?

I don’t know enough to figure if there’s something wrong with the build process. Here it goes anyway – in the slim chance that it might be helpful:

  • That touchpad still causes conflicts with some tablets for some reason. I’d try commenting it out to see what happens, from what I’ve read.
  • I once had problems getting my graphire to work properly, so I simplified my xorg.conf. One of the things I did was remove the Option “SendCoreEvents” “true” lines from the InputDevice sections and letting the InputDevice lines in the ServerLayout section specify that. It probably wouldn’t hurt commenting out the InputDevice options that set your speed, input fashion and input area range.

And… well, that’s all I got.

Thanks. I don’t think there’s a problem with xorg.conf because it worked well like this for a few months. I think an update or something I installed myself knocked it out.

For now I’m back in Windows. Dammit! But I’ve got Linux on a seperate hard drive so if anyone has any ideas it’s easy for me to test them.

Every time the kernel gets updated you need to build a new kernel module (and maybe update your udev rules.)
i’m presuming it’s a usb tablet pc otherwise you wouldn’t be patching right?

the way that your xorg.conf is setup may work but also may be intermittent…

with the zappacy patch you should be calling your devices TabletPCstylus1 (main stylus) type = stylus, TabletPCStylus2 type = stylus(touch capacitive etc) and TabletPCstylus3(eraser) type = eraser. Any other naming convention in xorg.conf will be unpredictable.

try following these howtos instead…

generic:
http://ubuntuforums.org/showthread.php?t=765915&page=1

Tabletpc specific:
http://ubuntuforums.org/showthread.php?t=765915&page=2

you may also be better off trying the latest development version:

Development: 0.8.1-4 which doesn’t require patching and doesn’t need a special naming convention in xorg.conf but does add a new type “touch” for capacitive touch.

heres the relevant portion from my xorg.conf (I’m still patching 0.8.0.3 and am using an hp tx2000)
don’t forget to update the server layout section too! You’ll note I’m identifying the driver by path whichever way you go you may want to try that as it seems to be more definitive than just by “wacom”

Section “InputDevice”
Identifier “TabletPCStylus”
Driver “wacom”
Option “ForceDevice” “ISDV4”
Option “Type” “stylus”
Option “SendCoreEvents” “true”
Option “Device”
“/dev/input/by-path/pci-0000:00:0b.1-usb-0:2.3:1.0-event-mouse”
Option “TopX” “225”
Option “TopY” “122”
Option “BottomX” “26365”
Option “BottomY” “16488”
Option “ClickForce” “1”
Option “Button2” “button 3”
Option “TPCButton” “off”

EndSection

Section “InputDevice”
Identifier “TabletPCStylus2”
Driver “wacom”
Option “ForceDevice” “ISDV4”
Option “Type” “stylus”
Option “SendCoreEvents” “true”
Option “Device”
“/dev/input/by-path/pci-0000:00:0b.1-usb-0:2.3:1.1-event-”
EndSection

Section “InputDevice”
Identifier “TabletPCStylus3”
Driver “wacom”
Option “ForceDevice” “ISDV4”
Option “Type” “eraser”
Option “SendCoreEvents” “true”
Option “Device”
“/dev/input/by-path/pci-0000:00:0b.1-usb-0:2.3:1.0-event-mouse”
EndSection

Michael W I think you’ve got it. I’m sure it’s one of those updates that did it - I need to turn that stuff off. If it’s not broke, don’t fix it, right?

I look at this tomorrow when I’m fresh - but thanks for the reply!

it’s a good idea to keep the updates “on” for security etc… just watch out for the kernel updates…those are the one’s that break the touchscreen!

I can go through the whole process of building the kernel module and updating the udev rules etc in around ten minutes these days, though first time it took me a whole afternoon!

When ubuntu gets around to using the 0.8.1 driver or better we won’t have to worry but they’re still back on 0.7.8 or so…don’t hold your breath!

What is your tablet ?
If it is not a Wacom, u should go take a look there, and there.

Micheal W - Is the risk of an older version of Linux being hacked all that high? Fixing this tablet driver is quite time consuming! I can probably get to where it’s a 10 minute thing like you, but, then a few months will go by and I’ll forget what I learned. Back to a half-a-day thing!

jywa - I’m on an Asus R1E tablet PC.

I gave the new instructions and driver a try, still nothing.

Here’s what I did -

Link

and the results of the commands neko18 requested at the end of his write up -

Link

Maybe these threads will be able to help you : http://ubuntuforums.org/search.php?searchid=47629764

It says "Sorry - no matches. Please try some different terms. "

Ok, in your Xorg.conf file you have

                        #    Option        "ForceDevice"    "ISDV4"        # Tablet PC ONLY 

the # at the start of the line comments it out.

As you are using a tablet PC i think you need this line “active”

I hope that that’s your problem as it’s easy to fix!

i also think that this line

Option        "Device"    "/dev/input/wacom" 

is ok, but if your touchscreen supports “touch” as well as “stylus” and your xorg.conf doesn’t have a “touch” device it may cause problems, then again it may not…

You can have a look in /dev/input/by-path and you shou;d have differnt enrtries for the touch and stylus part of the wacom driver… sadly, /dev/input/by-id has them combined but by path has them seperate…

I haven’t tried the latest driver yet… you may be better off (if the above doesn’t work) going to the forums on linuxwacom…

I think i could fix it if i was sat at your kit but am rather bad here as it’s tricky to track down,

from here i’m probably out of ideas by remote!

Sorry for the first link, i hope these ones will be better :

link 1

link 2

Michael W - are you sure the .8.1-4 driver doesn’t need to be patched?

I’ve uncommented the suggested lines in xorg.conf and added in a bunch of stuff from the old xorg.conf that worked - tablet remains non-functional.

edit -

Like Mykes I also don’t have a /dev/input/wacom device. Should I?

edit -

[email protected]:/dev/input$ ls -l /dev/input
total 0
drwxr-xr-x 2 root root 120 2008-09-08 12:51 by-id
drwxr-xr-x 2 root root 240 2008-09-08 12:51 by-path
crw-rw---- 1 root plugdev 13, 64 2008-09-08 12:47 event0
crw-rw---- 1 root plugdev 13, 65 2008-09-08 12:47 event1
crw-rw---- 1 root plugdev 13, 74 2008-09-08 12:51 event10
crw-rw---- 1 root plugdev 13, 75 2008-09-08 12:51 event11
crw-rw---- 1 root plugdev 13, 66 2008-09-08 12:47 event2
crw-rw---- 1 root plugdev 13, 67 2008-09-08 12:47 event3
crw-rw---- 1 root plugdev 13, 68 2008-09-08 12:47 event4
crw-rw---- 1 root plugdev 13, 69 2008-09-08 12:47 event5
crw-rw---- 1 root plugdev 13, 70 2008-09-08 12:47 event6
crw-rw---- 1 root plugdev 13, 71 2008-09-08 12:47 event7
crw-rw---- 1 root plugdev 13, 72 2008-09-08 12:47 event8
crw-rw---- 1 root plugdev 13, 73 2008-09-08 12:47 event9
crw-rw---- 1 root root 13, 63 2008-09-08 12:46 mice
crw-rw---- 1 root root 13, 32 2008-09-08 12:46 mouse0
crw-rw---- 1 root root 13, 33 2008-09-08 12:47 mouse1
crw-rw---- 1 root root 13, 34 2008-09-08 12:47 mouse2
crw-rw---- 1 root root 13, 35 2008-09-08 12:51 mouse3
crw-rw----+ 1 root plugdev 10, 223 2008-09-08 12:47 uinput

The lights are on but nobody’s home. Should there be 5 mice? I’ve got a bluetooth mouse, the synaptics touchpad, and a Nostromo n52 which might be registering as a mouse. That’s 3.

Another try using an earlier driver with the Zappacky patch -

What I did

and the results of the commands neko18 requested at the end of his write up -

Link

I also don’t have a /dev/input/wacom device. Should I?

Jywa - Unfortunately those threads pre-date the usb patch.

You absolutely should have /dev/input/wacom! if you don’t then you don’t have a working driver…

you are “restarting” fully at the end of the process? you can’t just re-startX!

I’ve tried to read your logs, but it’s pretty hard to see which are commands you entered and which are output…

                      <!--         @page { margin: 2cm }         P { margin-bottom: 0.21cm }     -->       [email protected]:~/Documents/wacom/linuxwacom-0.8.0-3$ sudo make install  

er, shouldn’t that be linuxwacom-0.8.1-4 in all instances ??? you do need to patch 0.8.0-3

whichever readme you are following triple check the commands are pointing to the right directories and it can be easy to miss the cd … when you uninstall from prebuilt too!
on no, wait… you were trying the patched one, my bad!

According to linuxwacom you don’t need to patch, but I haven’t tried the latest…
i had an issue with 0.8.1-3 not initialising properly at random on boot, that was before I found the “bypath” fix, but it did work without patching and 0.8.1-4 has more fixes

Ok, I’ve been through your output and it seems ok. Just no "wacom in /dev/input/
If you’re sure you fully re-booted…

Try using “event9” in xorg rather than wacom you never know!

Also for a tablet you probably shouldn’t have “cursor” in xorg and if you’re trying to get a patched driver to work you need to change all the names to the convention in my first post…

“wacom” seems to be just a symbolic link to event9 in my setup

Alright, one more time . . .

Thanks for the effort!