Tablet Problem (strafing)

I got a tablet not too long ago and am just now really working on it in Blender.

However, I am having one troubling problem: I cannot find a way to strafe, or move the 3D window along the user’s X and Y axis. This is the motion achieved simply with SHIFT + MMB beyond the tablet.

My Huion-brand tablet has six buttons. I set one of them up as SHIFT, and Blender apparently reads that, because “Shift” appears in the 3D view when I hit it. However, when I press that, and then move the stylus, it does not achieve the strafing effect.

Does anybody have any work-arounds for this problem of not being able to strafe (Shift + MMB) with a tablet? Thanks as always.

Unless you can map MMB to the nib you won’t pan in blender.
You need to map the MMB to one of the buttons of the pen.
That’s how it works in my antique bamboo.

Hmm. That’s discouraging, and the set-up interface for my tablet does not allow for setting the button to MMB (besides the ones on the stylus).

I found this old script for you.
it places navigating buttons in to the 3d view header, try it out., remove .blend and install it.

Don’t know if you understood me before but I meant the nib of the pen or stylus if you are calling the pen stylus, so the tablet has shift assigned and the pen has MMB assigned to be able to pan.

Thanks for the script - it’s a good Plan B. I’d definitely still like to be able to do it with a tablet hotkey, though.

Yes, I assigned “SHIFT” to one of the six buttons on the tablet. However, it still does not allow me to pan.

Don’t know the model you have but let assume it’s this one.

One button on the tablet has SHIFT assigned.
Now did you assign MMB to one of the side buttons of the pen?, if yes then you should hold both pressed in order to pan.

Yes, this is very similar to my model. I’ve assigned SHIFT to the third button from the bottom, and then the very top button. It is recognized as SHIFT, and yet the panning still does not work.

Forget the buttons on the tablet , forget the SHIFT.

Did you assign MMB to one of the buttons on the Pen ?.

Yes. The MMB is the button on the pen where my forefinger rests.

Ok now press that button on the pen and hover over the tablet, can you rotate the view , do not touch the tablet surface.
See if the pen button works.

Yes, rotating like that works perfectly.

Now hold shift first ( button on the tablet) then press the button on the pen to pan.
Hopefully it works.

That does not pan. Instead, I just rotate, as if SHIFT isn’t being pressed at all.

Ok try it by pressing shift on the keyboard.
If that doesn’t work then I don’t know what to tell you anymore.
I guess it’s a SHIFT problem somewhere :slight_smile:

I guess you know that you have to press SHIFT first then MMB.

Oh yeah, it has always worked on the keyboard. But the goal is obviously convenience and speed, and therefore not having to reach from one instrument to another. So that’s why I’m trying to figure out some way to do it with the tablet.

It would be more efficient to keep one hand on the keyboard anyway right? at least, thats how I typically operate, I only use the tablet as a replacement for a mouse in my right hand, and use all of the keyboard shortcuts with my left hand.

I imagine it’d be easier to have both hands close together - definitely how I draw on paper!

But it looks like I don’t have a choice in the matter, because every attempt to achieve it on the tablet itself has failed.

simple solution,makes working with tablet much easier.

How do you get those icons to appear? There’s an addon that ramboblender linked to earlier that’s similar, but where is that?

Simple solution is to enable emulate 3 button mouse in user preferences -> input. That way you can use alt+left mouse as middle mouse. Or with tablet, alt+drawing on the tablet rotates, alt+shift+draw pans, ctrl+alt+draw zooms. It’s similar to navigation in image editing/painting applications ***.

*** when keyboard + tablet combo is used