Tablet+Ubuntu?

Hey all,

Does anyone know a simple way of getting a tablet to work with Ubuntu, pressure sensitivity doesn’t have to work or anything, just the basic pointing and left clicking when it touches the tablet.

I’ve looked around and all I can find are huge lists of steps to edit various different files, which all seem a bit over the top, surely Ubuntu should be able to recognise a tablet in this day and age =/

All tablets I had so far worked more less OOTB with the wacom kernel and x server module, USB and serial alike.
And some of them where no wacom tablets.

Any place I can get them from?

I have a Trust TB7300 so I’m probably out of luck since it’s quite an obscure tablet brand. I’m also running Ubuntu 10.4 netbook, it’s on my old laptop hence the netbook version running, not sure if that’ll effect it in anyway.

I test drove Puppy Linux and wacom. Got it working, but there was an offset, and the installation process was a nightmare. Also, it would not load if the tablet wasn’t attached. Went back to windows.
Does Ubuntu work with hot plug and play wacom tablet?

I had exactly that tablet before, it installed horribly on windows and even worse on ubuntu. the times it actually worked it was a decent tablet though. but it had some kind of bipolar disease so it would only work half the time it got plugged in, and even then you had to connect/disconnect 5345451169times if you wanted to keep working with it, as i type i remember the days i had with it and all the memories pisses me off!
what i did was take it back to the store and blamed the drivers for not working, they let me switch to a wacom bamboo pen and touch small, which was actually a bit cheaper so i got some money back too.
this new tablet of mine is glorious, truly glorious, it works like a charm on windows and it works even better on ubuntu netbook edition, on an actual netbook, the weakest piece of cpu i have ever seen and yet it handles greatly with the tablet, the pressure sensitivity and all of its gadgets, although the touch functions are a bit off, it seems like people had solved those issues but i never use touch so i didn’t bother with it.
http://ubuntuforums.org/showpost.php?p=9119518&postcount=782

there was the very short novel “my tablet memories” by fredrik larsson.
what you should take with you from this is that trust is horrible and with wacom, you will be satisfied even if you buy the smallest oldest cheapest one, so if there is any way you can switch it, you should.
also, i will share with you a tip that i discovered a bit after i got my wacom tablet, regarding what size to choose, myt biggest concern with switching to bamboo was that i had to get a smaller one, because all the big ones are way more expensive and my brain kept saying that bigger is better. but in fact it is not. try sketching some on paper and determine how you sketch, do you mainly use large sweeping motions or do you tend to fiddle with details just moving the tip of the pen?
i would actually be better off with a larger tablet because i like to sweep across the entire paper. even so, i am much happier with my small bamboo than my large trust.

i hope it works out for you and i hope that deep in my rant you found at least some piece of wisdom. thank you for your time.

> aptitude search wacom

should give you
linuxwacom-0.X.X-X : the kernel module
xf86-input-wacom : the x server module

> sudo install linuxwacom-0.X.X-X xf86-input-wacom 

and thats that.
Then it should work already as mouse corepointer device after a reboot.

To get the full functionality you got to create 3 new input devices (cursor, pointer, eraser) in the xorg.conf and add them to the serverlayout as corepointers - but there are a gazillion tuts for that in the net.
It is just possible that your tablet is not under /dev/input/wacom but /dev/input something else, you got to find that out yourself.

I had a TB4200 once. It worked right away after installing the wacom modules.
The Trust tablets itself are utter crap. I gifted mine to a friend, it is unusable and Trust was even aware of it. If you let rest the pen on its tip, the cursor jumped around 10x10 pixel. Also during drawing, no straight line, all looked like someone with parkinsons desease had drawn it…
Trust’s response was more less: Yeh we know, thats how it is, sorry.
Trust my podex.

try this: http://ubuntuforums.org/showthread.php?t=1528329

Thanks guys, I’ll try out what’s been mentioned. It’s only for sketching while sitting in the garden, so if it doesn’t work, I can live with it.

Also, I found out that the problem with the jumping cursor, usually, unless you have a borked tablet is interference from the monitor. It’s a problem with their pen technology, but as Wacom isn’t the only one using their technology any more I expect to see some pretty good tablets coming out, which won’t break the bank. Which is extremely good news for us artists :slight_smile:

Oh and I have an old TB4200 lying around, I think that’s the model number, the big grey thing? That was an utterly atrocious tablet to use. The 7300 is a massive improvement, although not up there with wacom. Hopefully their next tablet based on SenTip’s Sirius will be better.

I use Linux Mint, which detects my Wacom Intuos 3 perfectly. I assume it should be the same for Ubuntu as its based on it.

As far as I know, Mint is a version behind, so you would still be using HAL, which was tossed in 10.04. Also, being that you have a nice wacom, it does work as does my old graphire because it is much more supported, as opposed to my ghetto-ass Medion and Daniel’s ghetto-ass Truth tablet (which is supported in the wizardpen drivers I linked to.)

Installed Mint on my desktop PC and the link does indeed work. thanks x9000 man :slight_smile:

The next tablet I plan on buying will be a Wacom, I’m quite interested in getting a Cintiq, so hopefully I won’t have this kind of problem again (Well maybe not as bad).

I had exactly that tablet before…but now…

what are you talking about? My wacom bamboo fun has been working out-of-the-box just great, pressure sensitivity and all, for at least the last 2 Ubuntu iterations. well, I’ve not upgraded to 10.04 yet and now I feel even less tempted…

My wacom works OOTB too, also in 10.04, but this thread is not about a wacom :rolleyes:

Why Ubuntu? I will install Mandriva on my tabletPC :slight_smile:

 	 	 	 	 		 	 	   	 	 		 			[cheap used notebooks](http://notebooks4fun.com/cheap-used-notebooks)

I can’t remember if it worked in Ubuntu OOTB, I think it may have, but every time I installed it I had problems with Nvidia drivers, so I thought I’d try Mint, and while it’s a little hard to get up and running, it’s really worth it.

Painting and sculpting with my tablet in Windows wasn’t a very experience, but on Mint it feels amazing.

Now I just need to figure out how to extend the file system size since I only chose to install it with 6GB.